Bug 169318 - amarok spec file missing kdebase-devel BuildRequires
amarok spec file missing kdebase-devel BuildRequires
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: amarok (Show other bugs)
4
All Linux
low Severity low
: ---
: ---
Assigned To: Aurelien Bompard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-26 18:30 EDT by mschout
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-15 14:06:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mschout 2005-09-26 18:30:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

Description of problem:
The amarok spec file is missing a BuildRequires: kdebase-devel

Amarok will not build properly without this.  In particular, the konqueror plugins are skipped if this is not present.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -ba -v amarok.spec on a machine without kdebase-devel installed.

Actual Results:  rpm build fails because of missing header file from kdebase-devel.  amarok needs
/usr/include/kde/konqsidebarplugin.h

from kdebase-devel

Expected Results:  rpms sould have build successfully.

Additional info:
Comment 1 Michael Schwendt 2005-09-26 19:56:28 EDT
Not true. kdemultimedia-devel requires kdebase-devel, so the build
requirements are complete.
Comment 2 mschout 2005-09-27 00:47:21 EDT
Ok.  Well, my kdemultimedia-devel rpm comes from kde-redhat.sourceforge.net
(which depends on both fedora extras, and the livna repo).  kdemultimedia-devel
from the kde-redhat.sourceforge.net repo does not require kdebase-devel.  I
should probably use the amarok RPM from kde-redhat, but it has a lower version
number than the one in "extras", so yum thinks the one in "extras" is more
recent.  That is why I went with the one from extras.
Comment 3 Aurelien Bompard 2005-09-27 04:23:28 EDT
In my rpm from extras:
$ rpm -ql amarok | grep konq
/usr/lib/kde3/konqsidebar_universalamarok.la
/usr/lib/kde3/konqsidebar_universalamarok.so
/usr/share/apps/konqsidebartng/add/amarok.desktop
/usr/share/apps/konqsidebartng/entries/amarok.desktop
/usr/share/apps/konqsidebartng/kicker_entries/amarok.desktop
/usr/share/apps/konqueror/servicemenus/amarok.desktop
/usr/share/apps/konqueror/servicemenus/amarok_append.desktop

So the konqueror plugin is built. Do you have the functionnality ? (click on the
wrench in the konqueror sidebar -> new -> amarok)
Comment 4 Michael Schwendt 2005-09-27 06:29:01 EDT
Then that is a packaging bug at kde-redhat.org in that the
kdemultimedia-devel package is incompatible with Fedora Core's
package.
Comment 5 Rex Dieter 2005-09-27 06:38:09 EDT
Since when does kdemultimedia-devel depend on kdebase-devel?  kde-redhat's
kdemultimedia-devel may well be incompatible in this regard, but don't jump the
gun to say it's a bug.

Regardless, if amarok needs /usr/include/kde/konqsidebarplugin.h and it is in
kdebase-devel, then it really should have
BR: kdebase-devel
Period.  IMO, depending on implicit deps of other packages to get kdebase-devel
 isn't wise.

Further, amarok's inclusion of
BR: kdemultimedia-devel
dates back to when it built/included the -akode engine, which it doesn't
build/use anymore, so it possibly could be dropped.
Comment 6 Michael Schwendt 2005-09-27 06:42:51 EDT
> Since when does kdemultimedia-devel depend on kdebase-devel?

At least since FC3.

> but don't jump the gun to say it's a bug.

Well, Amarok in Extras builds fine in "mock" as is, which means the
chain of build requirements is complete for a successful build. Where
it doesn't build, the problem is not Fedora Extras or Fedora Core.

> BR: kdebase-devel

Sure, FYI, I'm not one of those who fight all redundant BR.
Comment 7 Rex Dieter 2005-09-27 06:50:11 EDT
Michael said:
> Amarok in Extras builds fine in "mock" as is

Agreed (established in comment #3), which is why this ought to be considerred
low-priority.
Comment 8 Rex Dieter 2005-12-15 13:47:20 EST
Since you're updating things... can you add
BR: kdebase-devel
so I don't have to keep doing it when I sync kde-redhat against Extras?  (-:
Comment 9 Aurelien Bompard 2005-12-15 14:05:16 EST
Well, I guess it doesn't hurt. If it makes your life easier... :)

Note You need to log in before you can comment on or make changes to this bug.