Bug 169395 - (buggyphprpms) Buggy PHP-5.0 RPMS (including testing RPMS).
Buggy PHP-5.0 RPMS (including testing RPMS).
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-27 16:46 EDT by Nikolay Mirin
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 15:38:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikolay Mirin 2005-09-27 16:46:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
There is a problem with segmentation fault during the very finalization in the CLI-script, which uses PostgreSQL through TCP/IP. Local socket works fine. 
Besides that all scripts work OK.

The problem is fixed in the latest php5-STABLE.

Version-Release number of selected component (if applicable):
php-5.0.4, php-5.0.5

How reproducible:
Always

Steps to Reproduce:
1.Make a script that sets up a TCP/IP connection to PostgreSQL daemon
2.Run it
3.See the message after it is done
  

Additional info:
Comment 1 Joe Orton 2005-10-04 11:34:59 EDT
Please give a short script to reproduce the issue.

If a segfault is generated, please obtain a core dump:

 # yum install php-debuginfo
 # ulimit -c unlimited
 # php /run/my/script.php
 ...
 # gdb /usr/bin/php core.<pid>
Comment 2 Nikolay Mirin 2005-10-04 13:19:00 EDT
<?php

  echo "assd\n";
  pg_connect("host=localhost user=sad");
?>


Basically, even the connection parameters are fake,
so pg_connect call returns FALSE,
and at the end of the script it show "Segmentation Fault"

RPMS.
php-5.0.4-10.4
php-pear-5.0.4-10.4
php-pgsql-5.0.4-10.4
php-mbstring-5.0.4-10.4


Debugging session info:

GNU gdb Red Hat Linux (6.3.0.0-1.21rh)
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

Reading symbols from shared object read from target memory...(no debugging
symbols found)...done.
Loaded system supplied DSO at 0x71e000
Core was generated by `/usr/bin/php a.php'.
Program terminated with signal 11, Segmentation fault.

warning: svr4_current_sos: Can't read pathname for load map: Ошибка ввода/вывода

Reading symbols from /lib/libcrypt.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libcrypt.so.1
Reading symbols from /lib/libnsl.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libnsl.so.1
Reading symbols from /usr/lib/libaspell.so.15...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libaspell.so.15
Reading symbols from /usr/lib/libpspell.so.15...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libpspell.so.15
Reading symbols from /lib/libpcre.so.0...(no debugging symbols found)...done.
Loaded symbols for /lib/libpcre.so.0
Reading symbols from /usr/lib/libgmp.so.3...
(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libgmp.so.3
Reading symbols from /lib/tls/i686/libdb-4.3.so...(no debugging symbols
found)...done.
Loaded symbols for /lib/tls/i686/libdb-4.3.so
Reading symbols from /usr/lib/libcurl.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libcurl.so.3
Reading symbols from /usr/lib/libbz2.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libbz2.so.1
Reading symbols from /usr/lib/libz.so.1...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libz.so.1
Reading symbols from /lib/libresolv.so.2...
(no debugging symbols found)...done.
Loaded symbols for /lib/libresolv.so.2
Reading symbols from /lib/libm.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/libm.so.6
Reading symbols from /lib/libdl.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/libdl.so.2
Reading symbols from /usr/lib/libxml2.so.2...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libxml2.so.2
Reading symbols from /usr/lib/libgssapi_krb5.so.2...(no debugging symbols
found)...done.
Loaded symbols for /usr/lib/libgssapi_krb5.so.2
Reading symbols from /usr/lib/libkrb5.so.3...
(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libkrb5.so.3
Reading symbols from /usr/lib/libk5crypto.so.3...(no debugging symbols
found)...done.
Loaded symbols for /usr/lib/libk5crypto.so.3
Reading symbols from /lib/libcom_err.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/libcom_err.so.2
Reading symbols from /lib/libssl.so.5...(no debugging symbols found)...done.
Loaded symbols for /lib/libssl.so.5
Reading symbols from /lib/libcrypto.so.5...(no debugging symbols found)...done.
Loaded symbols for /lib/libcrypto.so.5
Reading symbols from /usr/lib/libkrb5support.so.0...
(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libkrb5support.so.0
Reading symbols from /usr/lib/libidn.so.11...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libidn.so.11
Reading symbols from /lib/libc.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /usr/lib/libstdc++.so.6...(no debugging symbols found)...done.
Loaded symbols for /usr/lib/libstdc++.so.6
Reading symbols from /lib/libgcc_s.so.1...(no debugging symbols found)...done.
Loaded symbols for /lib/libgcc_s.so.1
Reading symbols from /lib/libpthread.so.0...
(no debugging symbols found)...done.
Loaded symbols for /lib/libpthread.so.0
Reading symbols from /lib/ld-linux.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/ld-linux.so.2
Reading symbols from /lib/libnss_files.so.2...(no debugging symbols found)...done.
Loaded symbols for /lib/libnss_files.so.2
#0  0x0044a234 in ?? ()
(gdb) bt
#0  0x0044a234 in ?? ()
#1  0x0035460c in CRYPTO_lock () from /lib/libcrypto.so.5
#2  0x003a2082 in ERR_set_implementation () from /lib/libcrypto.so.5
#3  0x003a2935 in ERR_free_strings () from /lib/libcrypto.so.5
#4  0x002013d2 in Curl_SSL_cleanup () from /usr/lib/libcurl.so.3
#5  0x0020a7e6 in curl_global_cleanup () from /usr/lib/libcurl.so.3
#6  0x0808683b in zm_shutdown_curl ()
#7  0x081afb7e in module_destructor ()
#8  0x081b5727 in zend_hash_apply_deleter ()
#9  0x081b5937 in zend_hash_graceful_reverse_destroy ()
#10 0x081acdde in zend_shutdown ()
#11 0x0816cfff in php_module_shutdown ()
#12 0x081eaf32 in main ()
(gdb)
Comment 3 Nikolay Mirin 2005-10-04 13:21:35 EDT
BTW, I contacted php people before about the issue,
so they ask me to download and compile stable php source, what I did.

So, it worked, which meanse according to them, the bug is fixed on their side
Comment 4 Kayvan Sylvan 2006-07-11 21:57:31 EDT
I am seeing similar problems in php-5.0.5 (updates-testing) on x86_64.

In my case, trying to run phpMyAdmin fails with segmentation faults when trying
to connect to mysql db.

Side issue (related): Since the yum update from updates-testing, my drupal site
reports "Allowed memory size of 8388608 bytes exhausted" which I know is a
memory_limit issue (in /etc/php.ini). But, I have set memory_limit=64M,
restarted apache, and it still reports the same problem. Interestingly, if I set
memory_limit via .htaccess (add "php_value memory_limit 64M" to the appropriate
section) it seems to work.

What is going on?

I had to upgrade from the FC4 php-5.0.4 because of another bug ("mysqli"
extension does not seem to work correctly on x86_64/php-5.0.4).
Comment 5 Nikolay Mirin 2006-09-06 04:22:59 EDT
Hi! I have just upgraded to FC-5!
The problem is still there.

I solved it last time compiling my own PHP,
this time I just use local socket connections to Postgres instead of TCP.

But, God! I'll switch to FreeBSD, if this is such a pain to deal with/
Comment 6 Matthew Miller 2007-04-10 15:38:33 EDT
Fedora Core 4 is now completely unmaintained. These bugs can't be fixed in that
version. If the issue still persists in current Fedora Core, please reopen.
Thank you, and sorry about this.

Note You need to log in before you can comment on or make changes to this bug.