Bug 16943 - linuxconf trashes named.conf immediately
linuxconf trashes named.conf immediately
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-25 11:31 EDT by Charles R. Anderson
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:47:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/named.conf before Linuxconf changed it (1.87 KB, text/plain)
2000-08-25 11:32 EDT, Charles R. Anderson
no flags Details
/etc/named.conf after Linuxconf trashed it. (845 bytes, text/plain)
2000-08-25 11:33 EDT, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2000-08-25 11:31:04 EDT
Linuxconf trashed my named.conf.  This happened when I changed my eth0
interface from manual to DHCP.  No other changes were made.  The named.conf
was changed immediately after clicking Accept on the Basic Host Information
window, after which several error messages popped up about invalid syntax
in /etc/named.conf, and finally a message "DNS has been updated".  There
are several problems here:

1.  DNS shouldn't be changed when changing an interface configuration to
DHCP (or changing interface configuration at all for that matter). 
Certainly not DNS server configuration.

2.  Changes shouldn't be made until Activate Changes is selected once Quit
is selected from the main Linuxconf window.

3.  Comments shouldn't be removed by Linuxconf.

4.  named.conf parsing by Linuxconf is completely and utterly broken.

Attached are "before" and "after" named.conf files.
Comment 1 Charles R. Anderson 2000-08-25 11:32:44 EDT
Created attachment 2998 [details]
/etc/named.conf before Linuxconf changed it
Comment 2 Charles R. Anderson 2000-08-25 11:33:35 EDT
Created attachment 2999 [details]
/etc/named.conf after Linuxconf trashed it.
Comment 3 Nalin Dahyabhai 2000-09-12 16:23:19 EDT
Linuxconf has known problems in this module.  We are disabling it until it can
be thoroughly debugged.
Comment 4 Brent Fox 2002-06-05 12:12:33 EDT
Closing because we don't ship linuxconf anymore
Comment 5 Red Hat Bugzilla 2006-02-21 13:47:45 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.