Bug 169441 - Don't pull in extra crud when clients link against -lpqxx
Don't pull in extra crud when clients link against -lpqxx
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: libpqxx (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-28 08:29 EDT by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 10:53:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2005-09-28 08:29:35 EDT
Actually, 2 suggestions:

1.  Add to %prep section:
# Don't pull in extra crud when clients link 
perl -pi.no-pqlibs -e 's|@POSTGRES_LIB@||' pqxx-config.in

2.  Don't build/include libpqxx.a, adding --disable-static to %configure (and
removing libpqxx.a from the %files section, of course)
Comment 1 Andreas Bierfert 2005-09-28 10:40:21 EDT
1. ok... if you say so =)

2. done
Comment 2 Tomasz Ostrowski 2005-11-09 14:53:28 EST
Apropos 2.
Because subsequent libpqxx versions are normally not binary-compatible:
http://gborg.postgresql.org/project/libpqxx/faq/faq.php?faq_id=164

I'd rather leave libpqxx.a to make a static linking possible.
Comment 3 Rex Dieter 2005-11-09 21:21:42 EST
FYI, See
http://fedoraproject.org/wiki/PackagingGuidelines
14. Exclusion of Static Libraries
Comment 4 Andreas Bierfert 2005-11-10 01:57:03 EST
(In reply to comment #2)
I noticed that but I'd rather wait for a good upstream handling as I don't think
the reason they give is valid... to many projects beg to differ. So I will leave
as is for now... Afaik koffice is the only package needing lipqxx atm...

Note You need to log in before you can comment on or make changes to this bug.