Bug 169446 - [PATCH] a100u2w problems
[PATCH] a100u2w problems
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
RHEL3U7NAK
: FutureFeature
: 142924 (view as bug list)
Depends On:
Blocks: 170417
  Show dependency treegraph
 
Reported: 2005-09-28 09:35 EDT by Bastien Nocera
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-28 08:12:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
a100u2w-diff.txt (4.68 KB, patch)
2005-09-28 09:35 EDT, Bastien Nocera
no flags Details | Diff

  None (edit)
Description Bastien Nocera 2005-09-28 09:35:01 EDT
Every kernel up to the current RHEL3 U6 beta kernel contain a number of problems
in the a100u2w driver:
- Possible deadlocks:
(1) spinlock for pHCB->BitAllocFlagLock will be called twice in a row in
orc_device_reset() resulting in a deadlock.
(2) Wait routine which assumes interrupt was called with interrupts disabled. 
Bus reset sequence in orc_reset_scsi_bus() will call wait function
waitSCSIRSTdone() after spin_lock_irqsave() is called.  Since timer interrutps
are diabled, jiffies will not be updated and the system will stall.
(3) SCSI bus reset sequence will not finish if SCSI bus reset was called. 
During SCSI bus reset, firmware uses 0x1b to notice interrupts.  However,
a100u2w driver does not recognize 0x1b and reports DID_ERROR to SCSI layer. 
Therefore SCSI bus reset will terminate abnormally and the bus reset sequence
cannot finish.
- Stall on startup when a tape is being used while the system is rebooted. The
driver assumes that the bus will be reset, when in fact it might not have been.

The patch comes from Kosuke TATSUKAWA <tatsu@ab.jp.nec.com>, backported from the
current a100u2w driver from Initio.
Comment 1 Bastien Nocera 2005-09-28 09:35:01 EDT
Created attachment 119358 [details]
a100u2w-diff.txt
Comment 2 Ernie Petrides 2005-09-28 19:50:05 EDT
Bastien, the a100u2w driver is unsupported.  We generally don't expend
effort fixing unsupported drivers unless there is sufficient business
justification.  I'll leave that up to PM to decide.
Comment 7 Ernie Petrides 2005-10-06 19:29:53 EDT
*** Bug 142924 has been marked as a duplicate of this bug. ***
Comment 9 Tom Coughlan 2005-10-14 09:47:07 EDT
We do not have the resources to add support for this driver in RHEL 3 U7. devel_NAK.

Note You need to log in before you can comment on or make changes to this bug.