Bug 169462 - NVIDIA Quadro NVS280 graphics card mis-identified as FX 330
NVIDIA Quadro NVS280 graphics card mis-identified as FX 330
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: hwdata (Show other bugs)
4.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-28 11:35 EDT by Lonni J Friedman
Modified: 2014-03-16 22:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 13:50:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lonni J Friedman 2005-09-28 11:35:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050810 Firefox/1.0+

Description of problem:
On Red Hat 4 U1 with an NVIDIA Quadro NVS280, graphics card, a "lspci" command returns output for an FX 330:

05:00.0 VGA compatible controller: nVidia Corporation NV37GL [Quadro FX 
330] (rev a2) (prog-if 00 [VGA])
        Subsystem: nVidia Corporation: Unknown device 0215
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- 
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size 08
        Interrupt: pin A routed to IRQ 209
        Region 0: Memory at f8000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Region 2: Memory at f9000000 (32-bit, non-prefetchable) [size=16M]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA 
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [68] Message Signalled Interrupts: 64bit+ 
Queue=0/0 Enable-
                Address: 0000000000000000  Data: 0000
        Capabilities: [78] Express Legacy Endpoint IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, 
ExtTag-
                Device: Latency L0s <512ns, L1 <4us
                Device: AtnBtn- AtnInd- PwrInd-
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
                Device: MaxPayload 128 bytes, MaxReadReq 512 bytes
                Link: Supported Speed 2.5Gb/s, Width x16, ASPM L0s, Port 0
                Link: Latency L0s <2us, L1 <16us
                Link: ASPM Disabled RCB 128 bytes CommClk- ExtSynch-
                Link: Speed 2.5Gb/s, Width x16

Version-Release number of selected component (if applicable):
0.146.10.EL-1

How reproducible:
Always

Steps to Reproduce:
1. install an NVIDIA Quadro NVS280 card
2. boot into RHEL4-U1 
3. run lspci
  

Actual Results:  
05:00.0 VGA compatible controller: nVidia Corporation NV37GL [Quadro FX 
330] (rev a2) (prog-if 00 [VGA])
        Subsystem: nVidia Corporation: Unknown device 0215
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- 
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 0, Cache Line Size 08
        Interrupt: pin A routed to IRQ 209
        Region 0: Memory at f8000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Region 2: Memory at f9000000 (32-bit, non-prefetchable) [size=16M]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA 
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [68] Message Signalled Interrupts: 64bit+ 
Queue=0/0 Enable-
                Address: 0000000000000000  Data: 0000
        Capabilities: [78] Express Legacy Endpoint IRQ 0
                Device: Supported: MaxPayload 128 bytes, PhantFunc 0, 
ExtTag-
                Device: Latency L0s <512ns, L1 <4us
                Device: AtnBtn- AtnInd- PwrInd-
                Device: Errors: Correctable- Non-Fatal- Fatal- Unsupported-
                Device: RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
                Device: MaxPayload 128 bytes, MaxReadReq 512 bytes
                Link: Supported Speed 2.5Gb/s, Width x16, ASPM L0s, Port 0
                Link: Latency L0s <2us, L1 <16us
                Link: ASPM Disabled RCB 128 bytes CommClk- ExtSynch-
                Link: Speed 2.5Gb/s, Width x16

Expected Results:  The card should have been identified as what it actually is, a Quadro NVS280.

Additional info:
Comment 1 Bill Nottingham 2005-09-28 13:50:24 EDT
This is handled upstream at pcids.sf.net; please submit corrections there.
For Red Hat, we attempt to remain in sync with the upstream data as much as
possible.
Comment 2 Lonni J Friedman 2005-09-28 14:02:28 EDT
What upstream data specifically are you syncing from pcids.sf.net?  

That project looks like a placeholder, as there's no activity in it whatsoever
(even their cvs tree is empty).  

I suspect i'd be submitting into a black hole if i submitted a bug there (no one
has ever submitted bugs there before, bug count=0).
Comment 3 Bill Nottingham 2005-09-28 14:05:37 EDT
Arrgh, I can't type.

http://pciids.sourceforge.net/

Sorry about that.

Note You need to log in before you can comment on or make changes to this bug.