Bug 169475 - "gnome-screensaver" disables DPMS - no way to enable
"gnome-screensaver" disables DPMS - no way to enable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-28 13:10 EDT by Joachim Frieben
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-01 15:15:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2005-09-28 13:10:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.11) Gecko/20050914 Epiphany/1.8.0

Description of problem:
After installing "gnome-screensaver", display power management by
"xscreensaver" is not available anymore. This is what one would
expect. The bad thing is that neither "gnome-screensaver" nor
"gnome-power-manager" offer an alternative means of controlling this
feature. Even worse, "gnome-screensaver" disables DPMS. After typing
"xset dpms 600 900 1200", "xset -q" correctly reports:

"DPMS (Energy Star):
   Standby: 600    Suspend: 900    Off: 1200
   DPMS is Enabled
   Monitor is On".

After executing "gnome-screensaver-preferences", one obtains:

"DPMS (Energy Star):
   Standby: 600    Suspend: 900    Off: 1200
   DPMS is Disabled".

There is no intuitive way of reenabling DPMS. This possibility seems to
be missing from both "gnome-screensaver" and "gnome-power-manager".

Version-Release number of selected component (if applicable):
gnome-screensaver-0.0.13-5

How reproducible:
Always

Steps to Reproduce:
1. Enable DPMS, e.g. by typing "xset dpms 600 900 1200".
2. Check that DPMS is enabled by means of "xset -q".
3. Execute "gnome-screensaver-preferences".
4. Check if DPMS is enabled by means of "xset -q".
5. Verify that display really does not switch to stand-by mode.
  

Actual Results:  DPMS should be enabled.

Expected Results:  DPMS is disabled.

Additional info:

This behaviour occurs regardless of "gnome-power-manager" is installed
or not. If it is installed, at least the three time values are preserved,
otherwise thy are also altered. There is an entry in ".gconf/apps/..
../gnome-screensaver/%gconf.xml":

<entry name="dpms_suspend" mtime="1127925270" type="int" value="60">

Is this meant do suspend (deactivate?) DPMS?
Comment 1 Joachim Frieben 2005-09-28 13:51:14 EDT
Ok, ok - "gconf-editor" is your friend. DPMS is actually not checkmarked.
But this is easily done here. The same holds for "stand-by", "suspend" and
"off" delays. The content of "%gconf.xml" now reads:

<?xml version="1.0"?>
<gconf>
  <entry name="dpms_standby" mtime="1127929052" type="int" value="10">
  </entry>
  <entry name="dpms_off" mtime="1127929046" type="int" value="20">
  </entry>
  <entry name="dpms_enabled" mtime="1127929026" type="bool" value="true">
  </entry>
  <entry name="dpms_suspend" mtime="1127929060" type="int" value="15">
  </entry>
</gconf>

which makes a lot more sense to me.

It would be nice, of course, to be able to change these settings directly
in the preferences panel.
Comment 2 Joachim Frieben 2005-09-29 07:06:01 EDT
Unfortunately, "gnome-screensaver" does not retain the settings chosen by
means of "gconf-editor". The value of "dpms_suspend" in "%gconf.xml" is
always reset to 60 after some time. Still, even after logging out and
in again, "xset -q" reports the correct values. However, after rebooting
the machine, "xset -q" now reports:

"DPMS (Energy Star):
   Standby: 0    Suspend: 0    Off: 0
   DPMS is Enabled
   Monitor is On".

Very strange, because these value do not at all correspond to the values
shown by "gconf-editor".
Comment 3 Joachim Frieben 2005-10-17 14:42:30 EDT
As of "gnome-screensaver-0.0.16-1", "DPMS" is still disabled, albeit
"gconf-editor" having "dpms_enabled" checkmarked. "xset -q" reports:

  "DPMS (Energy Star):
   Standby: 1200    Suspend: 1800    Off: 2400
   DPMS is Disabled"

The values are correct, but "DPMS" itself is disabled.
Comment 4 Joachim Frieben 2005-11-14 04:17:22 EST
Still not functional in "gnome-screensaver-0.0.18-2".
Comment 5 Joachim Frieben 2005-11-23 14:21:18 EST
Still not functional in "gnome-screensaver-0.0.20-1". Btw, the menu
icon has not been adapted to the Bluecurve theme either.
Comment 6 Joachim Frieben 2005-12-17 12:35:19 EST
"DPMS" is still not working in "gnome-screensaver-0.0.22-1" despite
setting all relevant parameters through "gconf-editor" accordingly.
After the removal of "xscreensaver" from "rawhide", no working
screensaver for the "GNOME" desktop is left over.
Comment 7 Joachim Frieben 2005-12-20 07:57:55 EST
"DPMS" is still not working in "gnome-screensaver-0.0.22-3".
Comment 8 Joachim Frieben 2005-12-21 08:51:01 EST
"DPMS" is still not working in "gnome-screensaver-0.0.23-3".
Moreover, when I set "suspend" to 10 min by means of
"gconf-editor" it gets reset to 60 min automatically.
Comment 9 Joachim Frieben 2006-01-10 10:36:31 EST
It is possible to set "dpms_suspend" by means of "gnome-power-manager".
Changes applied by means of the latter instead of "gconf-editor" are
saved correctly and the display actually goes to power saving mode after
a while. "gnome-power-manager" should be definitely be required by
"gnome-screensaver" when installing it.
Comment 10 Joachim Frieben 2006-01-10 10:41:37 EST
There exists a corresponding upstream "GNOME" bug report at:

    http://bugzilla.gnome.org/show_bug.cgi?id=324419
Comment 11 jmccann 2006-04-26 12:08:35 EDT
This can probably be closed since gnome-screensaver doesn't handle DPMS in 2.14.

Note You need to log in before you can comment on or make changes to this bug.