Bug 169506 - sbcl missing sb-posix
sbcl missing sb-posix
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sbcl (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 170026
  Show dependency treegraph
 
Reported: 2005-09-29 00:17 EDT by Ben
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 09:11:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben 2005-09-29 00:17:44 EDT
First, thanks for getting this into Extras.

Just one enhancement request. The sb-posix contrib package seems to be missing.
Several Lisp programs won't work without it (Maxima, SLIME). Could this please
be added back? (It used to be in the http://math.ifi.unizh.ch/fedora/ SBCL
packages, and apparently still works in current SBCL releases because
fedoralisp.org includes it.)
Comment 1 Rex Dieter 2005-09-29 08:25:03 EDT
Certainly odd.  We've done nothing to omit sb-posix.

Any clues how/why it didn't get included?  Here's a link to the current build logs:
http://buildsys.fedoraproject.org/logs/4/1437-sbcl-0.9.5-8.fc4/

From the build.log, it *appears* sb-posix was at least built/compiled.  It's not
clear how/why it wasn't included in the final package.
Comment 2 Rex Dieter 2005-09-29 09:28:05 EDT
Gemi, any insight how/why sbcl's contrib/sb-posix didn't get included?  It seems
to get included in my local builds.  In install.sh, it appears to only
include/install contrib modules that have a 'tests-passed' file... perhaps
sb-posix isn't creating that on the buildsystem?
Comment 3 Gérard Milmeister 2005-09-29 09:48:35 EDT
You could make a diff of your local build log and the build server's.
I will make a mockbuild on my machine, and see what happens.
Comment 4 Rex Dieter 2005-10-06 13:14:50 EDT
Confirmed sb-posix is (still) missing from latest sbcl-0.9.5-15.fc4 build.
Comment 5 Rex Dieter 2005-10-27 13:36:17 EDT
I've tracked the cause down to a failure in
gmake -C contrib/sb-posix test

...
Test SB-POSIX-TESTS::STAT.2 failed
Form: (LET* ((SB-POSIX-TESTS::STAT (SB-POSIX:STAT "/"))
             (SB-POSIX-TESTS::MODE (SB-POSIX:STAT-MODE SB-POSIX-TESTS::STAT)))
        (LOGAND SB-POSIX-TESTS::MODE SB-POSIX:S-IWOTH))
Expected value: 0
Actual value: 2.
...
Test SB-POSIX-TESTS::STAT.4 failed
Form: (LET* ((SB-POSIX-TESTS::STAT
              (SB-POSIX:STAT (MAKE-PATHNAME :DIRECTORY '(:ABSOLUTE :UP))))
             (SB-POSIX-TESTS::MODE (SB-POSIX:STAT-MODE SB-POSIX-TESTS::STAT)))
        (LOGAND SB-POSIX-TESTS::MODE SB-POSIX:S-IWOTH))
Expected value: 0
Actual value: 2.
...

2 out of 42 total tests failed: SB-POSIX-TESTS::STAT.2,
SB-POSIX-TESTS::STAT.4.unhandled SIMPLE-ERROR in thread #<SB-THREAD:TH
READ "initial thread" {9003571}>:
  non-errno tests failed!

Good news is that in sbcl-0.9.6, these tests seem to pass and sb-posix gets
included.
Comment 6 Rex Dieter 2005-10-27 15:43:09 EDT
Ack, the tests pass on the development/fc5 build, but fail in fc3/fc4.  I'll
keep looking.
Comment 7 Rex Dieter 2005-12-01 09:11:50 EST
%changelog
* Thu Oct 27 2005 Rex Dieter <rexdieter[AT]users.sf.net> 0.9.6-5
- override (bogus/mock-induced) sb-posix test failure(s).

Note You need to log in before you can comment on or make changes to this bug.