Bug 169523 - autofs tries to mount from localhost if host not found
autofs tries to mount from localhost if host not found
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-29 07:12 EDT by Ian Collier
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 4.1.4-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-05 10:57:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Collier 2005-09-29 07:12:13 EDT
Description of problem:

If the host named in your map can not be found, autofs strips the host
name and looks for the remote mount point on the local host.  This results
in two error messages where one would have done.

Example: auto.users map contains

imc     beta,beta2,beta3:/fs13/imc

This is already broken by bug 160782, but let's pretend "beta,beta2,beta3" is
a single host name that can't be looked up.  In the message log, you get:

automount[634]: mount(nfs): host beta,beta2,beta3: lookup failure
automount[634]: >> mount: special device /fs13/imc does not exist

It's conceivable that this could sometimes lead to a special device being
mounted on your system that ought not to have been mounted.

Version-Release number of selected component (if applicable):
autofs-4.1.4-5 (but not fixed in autofs-4.1.4-9 either)

Additional info:

The autofs-4.1.4-non-replicated-ping.patch is (again) responsible.  The first
use of is_local_mount (in get_best_mount) doesn't bother to check the return
code, so if it returns an error then the code continues as if the function had
returned true.
Comment 1 Jeffrey Moyer 2005-10-21 12:51:18 EDT
Thanks, I'll take a look.
Comment 2 Jeffrey Moyer 2005-10-27 19:32:42 EDT
The latest rawhide package should address this issue.  The version is 4.1.4-11.

Can you give it a try?
Comment 3 John Thacker 2006-05-05 10:57:42 EDT
Closing due to lack of response.
Should be fixed.

Note You need to log in before you can comment on or make changes to this bug.