Bug 169530 - Running up2date with pdksh installed removes pdksh and installs ksh
Running up2date with pdksh installed removes pdksh and installs ksh
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ksh (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
: Regression
Depends On:
Blocks: 178252 187539
  Show dependency treegraph
 
Reported: 2005-09-29 08:57 EDT by Bastien Nocera
Modified: 2007-12-10 22:16 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0212
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-12 11:34:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2005-09-29 08:57:18 EDT
1. Install RHEL3 U5
2. Install pdksh
3. Subscribe the machine to the Extras channel
4. Run up2date
5. pdksh will be removed, and ksh installed instead

Because ksh "Obsoletes" pdksh, pdksh (which has more functionality than ksh,
"echo -e" working for example) will be removed in favour of ksh. This is a nasty
side effect of Bug #131303, and can cause problems with customers using pdksh
scripts in production.

Adding this to the U7 blockers but should probably be fixed before that as it
creates regressions.
The work-around is to unsubscribe the machine from the Extras channel in RHN.
Comment 1 Bastien Nocera 2005-10-03 04:49:36 EDT
Was worked around for RHEL4 in up2date in bug #148952.
Comment 15 Red Hat Bugzilla 2006-04-12 11:34:33 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0212.html

Note You need to log in before you can comment on or make changes to this bug.