Bug 169542 - X-Bugzilla-Status Mail Header field is needed for filtering
X-Bugzilla-Status Mail Header field is needed for filtering
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
urgent Severity urgent (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-29 10:37 EDT by Steve Dickson
Modified: 2013-01-10 16:42 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 10:30:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dickson 2005-09-29 10:37:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020

Description of problem:
If there was a 'X-Bugzilla-Status:' in  Bugzilla's mail header
it would allow people to filter out mail that is not interesting
to them. For example, engineering types could filter out the
following:
    X-Bugzilla-Status: ON_QA
    X-Bugzilla-Status: PASSES_QA
    X-Bugzilla-Status: RELEASE_PENDING

This would allow the volume that Bugzilla generates
to me more manageable... imho...

PS. while your there... you might as well as put in
a 'X-Bugzilla-Resolution:' as well since it could be
useful as well... 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Generate mail
2.
3.
  

Additional info:
Comment 1 David Lawrence 2005-09-29 13:05:46 EDT
Eventually the whole bug report will be in the mail headers and will no longer
need the body itself ;) Just kidding, I will see about adding these in as well.
Comment 2 Steve Dickson 2005-09-29 15:08:27 EDT
Well feel free to remove anything I don't want... :)
Comment 3 Steve Dickson 2005-12-01 08:59:06 EST
Is there any progress on this?
Comment 4 Steve Dickson 2006-08-14 08:52:16 EDT
Hello... hello... Calling from the depths of the deep whole.. anybody up there? :)

Now that PM has bots going through and change flags which generates
mails to everyone but them... We really need away to filer out this
needless, time wasting mail... 
Comment 5 David Lawrence 2006-08-16 10:28:53 EDT
X-Bugzilla-Status: %status% added to mail header. Running a test now.
Comment 6 David Lawrence 2006-08-16 10:30:30 EDT
Looks good. Closing. 

Note You need to log in before you can comment on or make changes to this bug.