Bug 169565 - Configuration tool silently omits lines
Configuration tool silently omits lines
Status: CLOSED DUPLICATE of bug 169564
Product: Fedora
Classification: Fedora
Component: system-config-httpd (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-29 13:57 EDT by bob mckay
Modified: 2015-03-04 20:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 14:37:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bob mckay 2005-09-29 13:57:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412.7 (KHTML, like Gecko) Safari/412.5

Description of problem:
Using system-config-httpd to create an ssl virtual server, I used the previous (fc3) locations for the 
keyfiles. This resulted in silent failure, with the relevant lines being omitted from the httpd.conf file, but 
no error message being generated. 

Version-Release number of selected component (if applicable):
system-config-httpd-1.3.2-2

How reproducible:
Always

Steps to Reproduce:
1.create an ip virtual server, set ssl on
2.create keys in the locations used for fc3
3.enter the locations in the key location dialogue boxes
  

Actual Results:  Tool closed normally and appeared to save, but created a crippled httpd.conf with many lines missing 
from the virtual server (all key configuration lines missing)

Expected Results:  The tool should give an error message that the locations are incorrect - this information is presumably 
available, since the tool was able to omit the erroneous lines.

Additional info:

The problem is going to bite hard as people switch to FC4; most of the documentation out there, including 
some referring to FC4, still describes the old key locations. This is especially true of documentation 
covering key creation. Some protection through the tool is needed.
Comment 1 David Lawrence 2005-09-29 14:37:31 EDT
Steps to Reproduce:
1.create an ip virtual server, set ssl on
2.create keys in the locations used for fc3
3.enter the locations in the key location dialogue boxes

*** This bug has been marked as a duplicate of 169564 ***

Note You need to log in before you can comment on or make changes to this bug.