Bug 169569 - Bad interactive performance under heavy disc I/O with 2.6.13-1.1526_FC4
Bad interactive performance under heavy disc I/O with 2.6.13-1.1526_FC4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-29 14:28 EDT by Gawain Lynch
Modified: 2015-01-04 17:22 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-05 03:15:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg for 2.6.13-1.1526_FC4 without/with "ide0=noprobe" (5.20 KB, text/plain)
2005-10-09 05:27 EDT, Peter Blomgren
no flags Details

  None (edit)
Description Gawain Lynch 2005-09-29 14:28:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:


Version-Release number of selected component (if applicable):
kernel-2.6.13-1.152[456]_FC4

How reproducible:
Always

Steps to Reproduce:
1. Start Rhythmbox
2. dd if=/dev/zero of=test bs=1M count=1024

  

Actual Results:  Symptoms include:
1. Rhythmbox stops playing or skips for a while and then stops
2. Switching workspaces can be delayed for up to 1 or more minutes
3. Mouse movement is very jerky and precision becomes impossible
4. pdflush and kjournald use up lots of CPU as shown in top



Expected Results:  Rhythmbox should keep playing.

System should still be usable interactively.

Additional info:

It may also be worth noting that if you kill dd then pdflush and kjournald stay chewing cycles until /bin/sync is run manually.

This does not happen with kernel-2.6.12-1.1398_FC4, but I am unable to boot any kernel in between so I am not sure if it affects any later 2.6.12 kernels.

The machine is a ThinkPad R52.
Comment 1 Pete Zaitcev 2005-09-29 14:46:57 EDT
I suspect it may have something with writes into an ext3.
I see the same effect when I run mkisofs. However, any other
disk activities have no effect on Rhythmbox, e.g. find, tar.
Kernel compiles do no harm either. It was like that since FC4 shipped
(I am on 2.6.13-1.1580_FC5 now)
Comment 2 Gawain Lynch 2005-09-29 15:11:30 EDT
Maybe, but I can also get the same effect when loading a VMware guest, which I
would have thought was mostly reads.
Comment 3 Dave Jones 2005-09-30 02:27:04 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 4 Peter Blomgren 2005-09-30 20:56:13 EDT
I'm experiencing this as well.  I installed kernel-2.6.13-1.1526_FC4 last night,
and my machine seemed sluggish, going back to kernel-2.6.12-1.1456_FC4 restored
the expected behavior.

In my case it seems like all disc I/O is slow, starting at boot-up.  Using the
very "scientific" method of looking at the drive-light: under 2.6.12-1.1456_FC4
the light is solid during I/O, but under 2.6.13-1.1526_FC4 is flashes rapidly...

This behavior seems to be hardware dependent, this is the affected HW configuration:

--- DELL-Precision-M70 --- /sbin/lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express
Processor to DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 915GM/PM Express PCI Express Root
Port (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI
Express Port 1 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family)
USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW
(ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem
Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus
Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation NV41 [Quadro FX Go1400]
(rev a2)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit
Ethernet PCI Express (rev 01)
03:01.0 CardBus bridge: Texas Instruments: Unknown device 8036
03:01.5 Communication controller: Texas Instruments: Unknown device 8038
03:03.0 Network controller: Intel Corporation PRO/Wireless 2200BG (rev 05)

Ideas?
Comment 5 Gawain Lynch 2005-10-01 18:05:40 EDT
Hi Dave,

Yes, this occurs with both 1525 and 1526 and as with Peter's experience, earlier
kernels do not display this behaviour.
Comment 6 Simon Wunderlin 2005-10-08 04:01:09 EDT
i am running debian sarge/testing with kernel 2.6.11/12 and 13. my acer
travelmate 4650 is using the same ide controller:

schleppi:~# lspci | grep -i ide
0000:00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller
(rev 04)

an i am using ext2 instead of the above reported ext3. 

i just came along this bug report and tought i'd add my 2 cents.

Cheers,
-S
Comment 7 Pradeep Picardo 2005-10-08 17:06:26 EDT
Happens to me too.
Kernel: 2.6.13-1.1526_FC4
Symptoms: commands cp and mv cause machine to freeze for very long periods,
kjournald+mv|cp+pdflush+kblockd take up 100% CPU.
machine: IBM Thinkpad T43
chipset: Intel Corporation Mobile 915GM/PM/GMS/910GML Express

If there's any other information you would like me to extract I'll be happy to
oblige.
Comment 8 Norman Gaywood 2005-10-08 17:51:23 EDT
I fixed my laptop (DELL D610) by adding ide0=noprobe to the kernel line in
/etc/grub.conf

I don't know why I should have to do that.
Comment 9 Gawain Lynch 2005-10-08 18:17:05 EDT
For the sake of completeness, my controlle is also:

IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
Comment 10 Pradeep Picardo 2005-10-08 18:23:16 EDT
ide0=noprobe worked for me too.
Only visible difference is that my hard disk is now seen as /dev/sda, whereas
with the problem kernel it was seen as /dev/hda. (Older kernels saw it as /dev/sda.)
Comment 11 Gawain Lynch 2005-10-08 18:45:47 EDT
ide0=noprobe worked for me also...
Comment 12 Pradeep Picardo 2005-10-08 19:14:42 EDT
There is this difference in /var/log/messages:

without ide0=noprobe:
Oct  8 05:21:31 loki kernel: SCSI subsystem initialized
Oct  8 05:21:31 loki kernel: ata: 0x1f0 IDE port busy
Oct  8 05:21:31 loki kernel: ata: 0x170 IDE port busy
Oct  8 05:21:31 loki kernel: ata_piix: probe of 0000:00:1f.2 failed with error -16

with ide0=noprobe:
Oct  8 18:20:29 loki kernel: SCSI subsystem initialized
Oct  8 18:20:29 loki kernel: ata: 0x170 IDE port busy
Oct  8 18:20:29 loki kernel: ata1: SATA max UDMA/133 cmd 0x1F0 ctl 0x3F6 bmdma
0x18C0 irq 14
Oct  8 18:20:29 loki kernel: ata1: dev 0 ATA, max UDMA/100, 117210240 sectors:

Comment 13 Peter Blomgren 2005-10-09 05:27:36 EDT
Created attachment 119743 [details]
dmesg for 2.6.13-1.1526_FC4 without/with "ide0=noprobe"
Comment 14 Peter Blomgren 2005-10-09 05:30:08 EDT
"ide0=noprobe" seems to have solved the problem for me as well.  Details in
attachment to comment #13.
Comment 15 Gawain Lynch 2005-10-21 14:36:30 EDT
The latest update kernel (2.6.13-1.1532_FC4) no longer displays this behaviour here.
Comment 16 Simon Roberts 2005-10-21 22:25:37 EDT
Yup, 1532 fixed it for me too. 

Note You need to log in before you can comment on or make changes to this bug.