Bug 169645 - killed by signal 6
killed by signal 6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: postfix (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-30 12:24 EDT by Shane A. Stillwell
Modified: 2014-01-21 17:52 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.2.10-1.RHEL4.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-09 11:24:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane A. Stillwell 2005-09-30 12:24:10 EDT
+++ This bug was initially created as a clone of Bug #156838 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2)
Gecko/20050502 Firefox/1.0+

Description of problem:
I'm seeing this in the /var/log/maillog:

May  2 12:57:43 dp postfix/smtp[31464]: panic: myfree: corrupt or unallocated
memory block
May  2 12:57:44 dp postfix/master[1606]: warning: process
/usr/libexec/postfix/smtp pid 31464 killed by signal 6

at first I suspected memory hardware problems, but then I realized this same is
happenings in two differents machines after I upgraded to postfix-2.1.5-5 (via
yum update)

I also see:

May  4 13:27:17 dp postfix/qmgr[31787]: warning: premature end-of-input on
private/smtp socket while reading input attribute name
May  4 13:27:17 dp postfix/qmgr[31787]: warning: private/smtp socket: malformed
response
May  4 13:27:17 dp postfix/qmgr[31787]: warning: transport smtp failure -- see a
previous warning/fatal/panic logfile record for the problem description
May  4 13:27:17 dp postfix/master[31783]: warning: process
/usr/libexec/postfix/smtp pid 31818 killed by signal 6

very weird...

Version-Release number of selected component (if applicable):
postfix-2.1.5-5

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:

-- Additional comment from twoerner@redhat.com on 2005-05-12 09:36 EST --
Please test if the FC-4 postfix has the same problem for you.

-- Additional comment from sergiokessler@gmail.com on 2005-05-12 15:24 EST --
well, I enabled the development repo of yum, and tryed:

# yum update postfix

Setting up Update Process
Setting up Repos
development               100% |=========================| 1.1 kB    00:00
...
...
Dependencies Resolved
Transaction Listing:
  Update: postfix.i386 2:2.2.2-2 - development

Performing the following to resolve dependencies:
  Install: audit-libs.i386 0:0.7.4-1 - development
  Install: libdbi-drivers.i386 0:0.7.1-3 - development
  Install: mysqlclient10.i386 0:3.23.58-6 - development
  Install: perl-BSD-Resource.i386 0:1.24-3 - development
  Update: MyODBC.i386 0:2.50.39-24 - development
  Update: MySQL-python.i386 0:1.2.0-1 - development
  Update: NetworkManager.i386 0:0.4-10.cvs20050404 - development
  Update: SysVinit.i386 0:2.85-39 - development
  Update: apr-util.i386 0:0.9.6-2 - development
  Update: arts.i386 8:1.4.0-1 - development
  Update: bc.i386 0:1.06-18 - development
  Update: bind.i386 24:9.3.1-2_FC4 - development
  Update: bind-libs.i386 24:9.3.1-2_FC4 - development
  Update: bind-utils.i386 24:9.3.1-2_FC4 - development
  Update: bluez-libs.i386 0:2.15-1 - development
  Update: bluez-utils.i386 0:2.15-7 - development
  Update: cadaver.i386 0:0.22.2-2 - development
  Update: cracklib-dicts.i386 0:2.8.2-1 - development
  Update: crypto-utils.i386 0:2.2-4 - development
  Update: cups.i386 1:1.1.23-15 - development
  Update: cups-libs.i386 1:1.1.23-15 - development
  Update: curl.i386 0:7.13.1-3 - development
  Update: cyrus-sasl.i386 0:2.1.20-5 - development
  Update: cyrus-sasl-md5.i386 0:2.1.20-5 - development
  Update: cyrus-sasl-plain.i386 0:2.1.20-5 - development
  Update: db4.i386 0:4.3.27-3 - development
  Update: dbus.i386 0:0.33-2 - development
  Update: dbus-glib.i386 0:0.33-2 - development
  Update: device-mapper.i386 0:1.01.01-1.0 - development
  Update: dhcpv6_client.i386 0:0.10-13 - development
  Update: distcache.i386 0:1.4.5-7 - development
  Update: dmraid.i386 0:1.0.0.rc7-4_FC4 - development
  Update: dovecot.i386 0:0.99.14-4.fc4 - development
  Update: elinks.i386 0:0.10.3-1 - development
  Update: fetchmail.i386 0:6.2.5-7 - development
  Update: ftp.i386 0:0.17-25 - development
  Update: glib2.i386 0:2.6.4-1 - development
  Update: hal.i386 0:0.5.1-1 - development
  Update: httpd.i386 0:2.0.54-8 - development
  Update: httpd-manual.i386 0:2.0.54-8 - development
  Update: initscripts.i386 0:8.10-1 - development
  Update: ipsec-tools.i386 0:0.5-4 - development
  Update: kdelibs.i386 6:3.4.0-6 - development
  Update: krb5-libs.i386 0:1.4-3 - development
  Update: krb5-workstation.i386 0:1.4-3 - development
  Update: lftp.i386 0:3.1.3-1 - development
  Update: libdbi.i386 0:0.7.2-2 - development
  Update: libdbi-dbd-mysql.i386 0:0.7.1-3 - development
  Update: libselinux.i386 0:1.23.10-2 - development
  Update: libsepol.i386 0:1.5.6-1 - development
  Update: libstdc++.i386 0:4.0.0-4 - development
  Update: libusb.i386 0:0.1.10a-1 - development
  Update: libwvstreams.i386 0:3.75.0-5 - development
  Update: libxml2.i386 0:2.6.19-1 - development
  Update: libxml2-python.i386 0:2.6.19-1 - development
  Update: lvm2.i386 0:2.01.08-2.1 - development
  Update: mod_perl.i386 0:2.0.0-0.rc5.3 - development
  Update: mod_ssl.i386 1:2.0.54-8 - development
  Update: mutt.i386 5:1.4.2.1-2 - development
  Update: mysql.i386 0:4.1.11-2 - development
  Update: mysql-devel.i386 0:4.1.11-2 - development
  Update: mysql-server.i386 0:4.1.11-2 - development
  Update: neon.i386 0:0.24.7-6 - development
  Update: nmap.i386 2:3.81-3 - development
  Update: openldap.i386 0:2.2.23-4 - development
  Update: openssh.i386 0:4.0p1-2 - development
  Update: openssh-clients.i386 0:4.0p1-2 - development
  Update: openssh-server.i386 0:4.0p1-2 - development
  Update: openssl.i686 0:0.9.7f-6 - development
  Update: pam.i386 0:0.79-8 - development
  Update: pam_ccreds.i386 0:1-6 - development
  Update: parted.i386 0:1.6.22-2 - development
  Update: perl.i386 3:5.8.6-10 - development
  Update: perl-DBD-MySQL.i386 0:2.9007-1 - development
  Update: perl-DBD-Pg.i386 0:1.41-1 - development
  Update: php.i386 0:5.0.4-9 - development
  Update: php-ldap.i386 0:5.0.4-9 - development
  Update: php-mysql.i386 0:5.0.4-9 - development
  Update: php-odbc.i386 0:5.0.4-9 - development
  Update: php-pear.i386 0:5.0.4-9 - development
  Update: php-pgsql.i386 0:5.0.4-9 - development
  Update: postgresql-libs.i386 0:8.0.2-2 - development
  Update: postgresql-python.i386 0:8.0.2-2 - development
  Update: pyOpenSSL.i386 0:0.6-1.p24.4 - development
  Update: python.i386 0:2.4.1-1 - development
  Update: readline.i386 0:5.0-3 - development
  Update: sendmail.i386 0:8.13.4-2 - development
  Update: squid.i386 7:2.5.STABLE9-4 - development
  Update: stunnel.i386 0:4.08-2 - development
  Update: udev.i386 0:057-5 - development
  Update: unixODBC.i386 0:2.2.11-1 - development
  Update: webalizer.i386 0:2.01_10-28 - development
  Update: wget.i386 0:1.9.1-22 - development
  Update: wireless-tools.i386 1:28-0.pre4.3 - development
  Update: xmlsec1.i386 0:1.2.7-4 - development
  Update: xmlsec1-openssl.i386 0:1.2.7-4 - development
Total download size: 91 M
Is this ok [y/N]:

that's a LOTS of packages...
sorry, I can't do that on a production system...
maybe that will fix postfix, but may ruin the whole system
(I know for sure yum broke with python-2.4, which is listed)


is there another way ?

-- Additional comment from twoerner@redhat.com on 2005-05-13 05:04 EST --
You could rebuild the new postfix package from the source rpm.

-- Additional comment from sergiokessler@gmail.com on 2005-05-16 11:35 EST --
ok, I downloaded the postfix src.rpm and some devel packages, rebuild & installed.

good news, the deferred queue started to drop quickly and there is no more
'killed by signal' 6 until now, but I have to wait till tomorrow to really
verify this...
(I will keep you informed)

-- Additional comment from twoerner@redhat.com on 2005-06-21 06:16 EST --
Did the problem occure again?

-- Additional comment from sergiokessler@gmail.com on 2005-06-21 10:37 EST --
nope, the upgrade to the FC4 postfix src.rpm solved the problem.
thanks very much.

-- Additional comment from shane@ecitadel.com on 2005-06-23 13:47 EST --
I am having this same problem on a RHEL 4 machine.

It just started after upgrading from RHEL 3, so I'm pretty sure it's not really
a memory module problem and it's ECC ram too.  

I'm running the stock RHEL 4 rpm (postfix-2.1.5-4.2.RHEL4.)  I have not tried
recompiling, but maybe I should. 

It only happens when I am sending out our weekly newsletter, I've even throttled
the smtp (outgoing) process to 10 concurrent connections.


-- Additional comment from shane@ecitadel.com on 2005-06-30 16:26 EST --
I hope I am not speaking too soon.

In trying to fix this issue I recompiled my postfix version from an SRPM
(2.1.5-4.2.RHEL4) and that did not fix the problem.  

Just this morning I got the Fedora4 SRPM and compiled/installed it, it has not
had a crash since and under the old version it would have by now.

I am going to chalk this up to a bad version of postfix mainly 2.1.5-4.2.RHEL4.



-- Additional comment from twoerner@redhat.com on 2005-09-30 12:03 EST --
Shane: Please open up a new bugzilla for this and assign to RHEL-4.
Comment 1 Shane A. Stillwell 2005-09-30 12:29:05 EDT
I got the Postfix-2.2.2-2 SRPM from the fedora Core 4 repositories and compiled
it on my machine.  That solved the problem.  I haven't had a crash since.
Comment 2 Cory Wagner 2005-10-10 13:04:55 EDT
I am also having this same problem with 2.1.5-4.2.RHEL4 on RHEL 4 2.6.9-11.ELsmp
x86_64. I also downloaded postfix-2.2.2-2.src.rpm for Fedora Core 4, but it
won't install. This is what I get when I try to install:
# rpm -i postfix-2.2.2-2.src.rpm
warning: postfix-2.2.2-2.src.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2

The package does not get installed.

When is the 2.1.5 package going to get fixed?
Comment 3 Shane A. Stillwell 2005-10-10 13:11:54 EDT
Cory,

You might want to --force it or install the key from fedora into your rpm.  It
looks like it is just complaining because it can't verify the package.
Comment 4 Cory Wagner 2005-10-10 15:28:27 EDT
Thanks Shane, I ran rpm --import /usr/share/rhn/RPM-GPG-KEY-fedora to import the
Fedora GPG key. I'm pretty sure it worked without it, I just didn't realize that
it was putting the files in /usr/src/redhat/SOURCES, until I turned up the
verbosity of rpm (-vv).

A working Postfix would have been easier.
Comment 7 Thomas Woerner 2006-01-11 05:28:59 EST
Ok, here is what I should know:

1) Is tls used?
2) Is ipv6 in use?
3) If not, is the package working without the additional ipv6 and tls patches
for the customer?
4) Is there a test case? I was not able to reproduce the problem for my own.

Comment 8 Shane A. Stillwell 2006-01-11 08:23:42 EST
Thomas,  thanks for looking into this. To answer your questions.

1. TLS.  Yes, it was used and configured
2. IPv6. It was probably patched for IPv6, but I did not employ it.
3. I did not check the postfix program without the tls and ipv6 patches.
4. This whole bug is kind of a moot point for me right now as the server that
was having the problem has been fixed by installing the FC4 postfix as mentioned
above.  I do not have another server like it to use as a test machine.  This is
a production server.

I assume that a bug like this is hard to track down.  This issue has been solved
for me, so I have no objections to closing this bug.
Comment 11 Cory Wagner 2006-01-11 16:50:10 EST
Thomas, I'm still seeing this problem with 2.1.5-4.2.RHEL4 on at least one host
x86_64. I need to get this fixed, but I want to get a patch, too.

1) Is tls used?
No
2) Is ipv6 in use?
No
3) If not, is the package working without the additional ipv6 and tls patches
for the customer?
No
4) Is there a test case? I was not able to reproduce the problem for my own.
The problem appears to occur whenever we sent a lot of mail. On one host, were
we are sending out bursts of about 20K of messages several times a day, we are
seeing at least two "warning: process /usr/libexec/postfix/smtp pid 9709 killed
by signal 6" messages per mailing.

I'm also seeing tens of thousands of these messages daily "status=deferred
(delivery temporarily suspended: unknown mail transport error)." This appears to
be related, because the other server that shares the mail load, and is running
postfix-2.2.2-2.src.rpm, isn't logging these errors.

Please let me know ASAP what other info you need. 
Comment 18 Seth Vidal 2006-03-06 11:22:46 EST
Is it likely that we'll see an upgrade to the postfix package from fedora core 4
for update 3?

I'm curious b/c I'm seeing the same segfaults on two boxes and I'd like it to go
away. :)
Comment 22 Cory Wagner 2006-09-14 11:54:11 EDT
RHEL's postfix-2.2.2 continues to carry this bug for systems that deliver a lot
of messages. I suggest that you use Fedora's postfix-2.2.2-2.src.rpm (or later)
for a reliable version of Postfix on RHEL.
Comment 23 Thomas Woerner 2006-09-14 12:00:54 EDT
The postfix version in RHEL-4-4 is 2.2.10 and not 2.2.2.

Please verify with postfix-2.2.10.
Comment 24 Cory Wagner 2006-09-14 14:12:13 EDT
Sorry, another admin gave me the wrong version information. I have done a lot
more digging to find out why the problem was suddenly so much worse today. What
I found is that we were running postfix-2.1.5-4.2.RHEL4 until yesterday, when
up2date automatically installed postfix-2.1.5-4.2.RHEL4. Stopping and starting
all instances of Postfix resolved the error messages (below).

grep postfix /var/log/up2date:
up2date:[Wed Sep 13 16:18:04 2006] up2date installing packages:
['postfix-2.2.10-1.RHEL4.2']
up2date:[Wed Sep 13 16:18:11 2006] up2date Removing packages from package
profile: ['postfix-2.1.5-4.2.RHEL4']
up2date:[Wed Sep 13 16:18:20 2006] up2date Adding packages to package profile:
['postfix-2.2.10-1.RHEL4.2']
up2date:[Wed Sep 13 16:18:23 2006] up2date deleting
/var/spool/up2date/postfix-2.2.10-1.RHEL4.2.x86_64.hdr
up2date:[Wed Sep 13 16:18:23 2006] up2date deleting
/var/spool/up2date/postfix-2.2.10-1.RHEL4.2.x86_64.rpm


Here is a sample of what we were seeing in the maillog with postfix-2.1.5-4.2.RHEL4:
Sep 11 03:12:33 abraham postfix/smtp[10112]: panic: myfree: corrupt or
unallocated memory block
Sep 11 03:12:34 abraham postfix/master[2181]: warning: process
/usr/libexec/postfix/smtp pid 10112 killed by signal 6
Sep 11 03:12:34 abraham postfix/qmgr[2189]: warning: premature end-of-input on
private/smtp socket while reading input attribute name
Sep 11 03:12:34 abraham postfix/qmgr[2189]: warning: private/smtp socket:
malformed response
Sep 11 03:12:34 abraham postfix/qmgr[2189]: warning: transport smtp failure --
see a previous warning/fatal/panic logfile record for the problem description

The "panic: myfree" appears six or seven times a week and the other lines appear
nearly the same number of times -- about 50 times a week -- from delivery of
about 100,000 messages two times a week.


Here are the messages which started immediately after the upgrade to
postfix-2.2.10-1.RHEL4.2.x86_64.rpm:
Sep 13 16:18:09 abraham sendmail[4251]: alias database /etc/aliases rebuilt by root
Sep 13 16:18:10 abraham postfix/master[4298]: fatal: bind 127.0.0.1 port 25:
Address already in use
Sep 13 16:19:56 abraham postfix/master[2310]: warning: master_status_event:
partial status (4 bytes)
Sep 13 16:19:56 abraham postfix/master[2181]: warning: master_status_event:
partial status (4 bytes)
Sep 13 16:19:56 abraham postfix/master[2238]: warning: master_status_event:
partial status (4 bytes)
Sep 13 16:19:56 abraham postfix/master[2366]: warning: master_status_event:
partial status (4 bytes)
Sep 13 16:19:56 abraham postfix/master[2181]: warning: master_status_event:
partial status (4 bytes)
Sep 13 16:19:56 abraham postfix/master[2310]: warning: master_status_event:
partial status (4 bytes)
Sep 13 16:19:56 abraham postfix/master[2238]: warning: master_status_event:
partial status (4 bytes)
Sep 13 16:19:56 abraham postfix/master[2366]: warning: master_status_event:
partial status (4 bytes)
Sep 13 16:20:02 abraham sendmail[4387]: alias database /etc/aliases rebuilt by root
Sep 13 16:20:03 abraham postfix/master[4433]: fatal: bind 127.0.0.1 port 25:
Address already in use
Sep 13 16:21:04 abraham postfix/master[2181]: warning: master_status_event:
partial status (4 bytes)
Sep 13 16:21:04 abraham postfix/qmgr[2189]: warning: unexpected attribute flags
in input from private/rewrite socket
Sep 13 16:21:04 abraham postfix/qmgr[2189]: warning: problem talking to service
rewrite: Success
Sep 13 16:21:04 abraham postfix/master[2181]: warning: master_status_event:
partial status (4 bytes)
Sep 13 16:21:05 abraham postfix/qmgr[2189]: warning: unexpected attribute flags
in input from private/rewrite socket
Sep 13 16:21:05 abraham postfix/qmgr[2189]: warning: problem talking to service
rewrite: Success
Sep 13 16:21:06 abraham postfix/master[2181]: warning: master_status_event:
partial status (4 bytes)
Sep 13 16:21:06 abraham postfix/qmgr[2189]: warning: unexpected attribute flags
in input from private/rewrite socket

I was seeing similar messages on other hosts that were just upgraded to
postfix-2.2.10-1.RHEL4.2.x86_64.rpm.
Sep 14 11:06:26 freedom postfix/master[2340]: warning: master_status_event:
partial status (4 bytes)
Sep 14 11:06:26 freedom postfix/master[2340]: warning: master_status_event:
partial status (4 bytes)
Sep 14 11:07:23 freedom postfix/master[2284]: warning: master_status_event:
partial status (4 bytes)
Sep 14 11:08:23 freedom last message repeated 2 times
Sep 14 11:08:23 freedom postfix/master[2284]: warning: master_status_event:
partial status (4 bytes)
Sep 14 11:08:26 freedom postfix/master[2340]: warning: master_status_event:
partial status (4 bytes)
Sep 14 11:09:26 freedom last message repeated 2 times
Sep 14 11:09:26 freedom postfix/master[2340]: warning: master_status_event:
partial status (4 bytes)
Sep 14 11:10:23 freedom postfix/master[2284]: warning: master_status_event:
partial status (4 bytes)
Sep 14 11:11:23 freedom last message repeated 2 times
Comment 25 Thomas Woerner 2006-09-15 06:08:22 EDT
Could it be that you are using sendmail and postfix at the same time?

Please check.
Comment 26 Cory Wagner 2006-09-18 17:37:05 EDT
> Could it be that you are using sendmail and postfix at the same time?

Both Postfix and Sendmail were installed, but Sendmail was not configured or
running. Sendmail has been removed.

Also, postfix-2.2.10-1.RHEL4.2.x86_64.rpm appears to resolve this bug.
Comment 28 Thomas Woerner 2007-03-09 11:24:41 EST
According to comment #26 this bug is resolved by postfix-2.2.10-1.RHEL4.2, which
is part of U4.

Note You need to log in before you can comment on or make changes to this bug.