Bug 169670 - Problem with parameters to build_ext.py swig_sources
Problem with parameters to build_ext.py swig_sources
Status: CLOSED DUPLICATE of bug 168119
Product: Fedora
Classification: Fedora
Component: Pyrex (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-30 16:51 EDT by Dave Malcolm
Modified: 2013-03-13 00:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 17:01:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Malcolm 2005-09-30 16:51:00 EDT
Description of problem:
> [dmalcolm@cassandra pyspi]$ make
> python setup.py build_ext --inplace
> running build_ext
> building 'atspi' extension
> Traceback (most recent call last):
>   File "setup.py", line 52, in ?
>     cmdclass = {
>   File "/usr/lib/python2.4/distutils/core.py", line 149, in setup
>     dist.run_commands()
>   File "/usr/lib/python2.4/distutils/dist.py", line 946, in run_commands
>     self.run_command(cmd)
>   File "/usr/lib/python2.4/distutils/dist.py", line 966, in run_command
>     cmd_obj.run()
>   File "/usr/lib/python2.4/distutils/command/build_ext.py", line 279, in
> run
>     self.build_extensions()
>   File "/usr/lib/python2.4/distutils/command/build_ext.py", line 405, in
> build_extensions
>     self.build_extension(ext)
>   File "/usr/lib/python2.4/distutils/command/build_ext.py", line 442, in
> build_extension
>     sources = self.swig_sources(sources, ext)
> TypeError: swig_sources() takes exactly 2 arguments (3 given)
> make: *** [all] Error 1

This is seen on rawhide and on FC4 boxes

http://tallest.boston.redhat.com/pyrex has a patch we want you to apply (and get
upstream).
Comment 1 Dave Malcolm 2005-09-30 16:53:22 EDT
Works on a RHEL4 box, though (with python 2.3); I think it's a python 2.4-ism
Comment 3 Dave Malcolm 2005-09-30 17:01:56 EDT

*** This bug has been marked as a duplicate of 168119 ***
Comment 4 John (J5) Palmieri 2005-09-30 17:23:17 EDT
building now
Comment 5 Fedora Update System 2005-09-30 17:47:32 EDT
From User-Agent: XML-RPC

Pyrex-0.9.3-2 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.