Bug 169685 - NFSD: recovery directory /var/lib/nfs/v4recovery doesn't exist
NFSD: recovery directory /var/lib/nfs/v4recovery doesn't exist
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
: 189177 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-09-30 23:40 EDT by Ralf Corsepius
Modified: 2013-01-09 22:39 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-16 14:54:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2005-09-30 23:40:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Fedora/1.7.12-1.5.1

Description of problem:
During bootup I am seeing this error messages:
Oct  1 05:05:46 mccallum kernel: NFSD: Using /var/lib/nfs/v4recovery as the NFSv4 state recovery directory
Oct  1 05:05:46 mccallum kernel: NFSD: recovery directory /var/lib/nfs/v4recovery doesn't exist
Oct  1 05:05:46 mccallum kernel: NFSD: starting 90-second grace period

Googling for the subject seems to indicate this to be caused by the most recent kernel update (kernel-2.6.13-1.1526_FC4.i686), but I haven't investigated in depth.

I.e. I am not sure if this isn't a kernel bug, or an nfs-utils or an nfs-utils/kernel compatibility issue, nor am I sure about the effects stemming from this.

Version-Release number of selected component (if applicable):
nfs-utils-1.0.7-11/kernel-2.6.13-1.1526_FC4

How reproducible:
Always

Steps to Reproduce:
1. Upgrade an FC4 system with nfs enabled to kernel-2.6.13-1.1526_FC4
2. reboot

  

Additional info:

Manually creating /var/lib/nfs/v4recovery seems to silence this warning.
Comment 1 Charles R. Anderson 2006-05-30 13:20:49 EDT
nfs-utils-1.0.7-13.FC4 still doesn't have the missing /var/lib/nfs/v4recovery
directory added to the package.
Comment 2 Charles R. Anderson 2006-05-30 13:27:25 EDT
The same problem exists on FC5 with nfs-utils-1.0.8.fc2-5.FC5.  Can the
submitter or someone else with privs move the Version to fc5?
Comment 3 Kam Leo 2006-07-17 03:21:48 EDT
(In reply to comment #2)
> The same problem exists on FC5 with nfs-utils-1.0.8.fc2-5.FC5.  Can the
> submitter or someone else with privs move the Version to fc5?
> 

Still present in nfs-utils-1.0.8.2.fc5. 

By the way, changing the version of FC is not that important. Getting the
maintainer of nfs-utils to look at this bug and fix it is more important. 
Comment 4 Steve Dickson 2006-07-24 14:35:44 EDT
fixed in nfs-utils-1.0.8-3.fc5
Comment 5 Charles R. Anderson 2006-08-17 13:21:51 EDT
When is nfs-utils-1.0.8-3.fc5 actually going to be released to the repository?
Comment 6 Steve Dickson 2006-08-18 18:17:12 EDT
Sorry about that... I guess I never added that version to the update que...
I have now....
Comment 7 Zing 2006-08-24 10:31:34 EDT
hrmm, v4recovery directory needs to be added to the %files section. 
Comment 8 Steve Dickson 2006-12-06 20:42:34 EST
Fixed in nfs-utils-1.0.8-4.fc5
Comment 9 Charles R. Anderson 2007-04-16 18:08:02 EDT
Fix verified in FC5, FC6, F7.  I suggest that this bug be closed.

Comment 10 Peter van Egdom 2007-11-16 14:48:48 EST
*** Bug 189177 has been marked as a duplicate of this bug. ***
Comment 11 Peter van Egdom 2007-11-16 14:54:31 EST
Closing as per comment #9.

Note You need to log in before you can comment on or make changes to this bug.