Bug 169689 - fc4 x86_64 kernel panic after update. bad scsi initrd?
fc4 x86_64 kernel panic after update. bad scsi initrd?
Status: CLOSED DUPLICATE of bug 169610
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-01 03:33 EDT by Dale Bewley
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 17:02:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dale Bewley 2005-10-01 03:33:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Sun v20z dual Opteron 244, 2G RAM, 2 x 36G SCSI, software RAID1, LVM. 
Fresh KS install of FC4 then fully patched on 2 identical systems.

Original 2.6.11-1.1369_FC4smp kernel boots fine, 2.6.13-1.1526_FC4smp panics during md initilization. Apparently because it doesn't see the drives.

Tried the following:
boot off original kernel
mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu
rpm -e kernel-smp-2.6.13-1.1526_FC4 kernel-2.6.13-1.1526_FC4
yum update kern\*

But, the result was the same. 

Contents of modprobe.conf before:
# cat /etc/modprobe.conf
alias eth0 tg3
alias eth1 tg3
alias scsi_hostadapter mptbase
alias scsi_hostadapter1 mptscsih
alias usb-controller ohci-hcd

Contents after kudzu:
# cat /etc/modprobe.conf
alias eth1 tg3
alias eth0 tg3
alias scsi_hostadapter mptscsih
alias usb-controller ohci-hcd


Version-Release number of selected component (if applicable):
2.6.13-1.1526_FC4smp

How reproducible:
Always

Steps to Reproduce:
1. install FC4
2. yum update
3. reboot
  

Actual Results:  ...
powernow-k8: Power state transitions not supported
Freeing unused kernel memory: 216k freed
Fusion MPT base driver 3.03.02
Copyright (c) 1999-2005 LSI Logic Corporation
SCSI subsystem initialized
device-mapper: 4.4.0-ioctl (2005-01-12) initialised: dm-devel@redhat.com
md: raid1 personality registered as nr 3
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
cdrom: open failed.
cdrom: open failed.
Kernel panic - not syncing: Attempted to kill init!

Call Trace:<ffffffff80134eb1>{panic+133} <ffffffff80171155>{unmap_region+351}
       <ffffffff8033dd9c>{__down_read+50} <ffffffff801fd8b3>{__up_read+19}
       <ffffffff801378e8>{do_exit+168} <ffffffff801fda7c>{__up_write+29}
       <ffffffff8013857d>{sys_exit_group+0} <ffffffff8010d99e>{system_call+126}


Expected Results:  ...
powernow-k8: Power state transitions not supported
ACPI wakeup devices:
PCI0 THOR USB0 <7>Losing some ticks... checking if CPU frequency changed.
USB1 Z000 Z002
ACPI: (supports S0 S1 S5)
CPU0 attaching sched-domain:
 domain 0: span 00000001
  groups: 00000001
  domain 1: span 00000001
   groups: 00000001
   domain 2: span 00000003
    groups: 00000001 00000002
CPU1 attaching sched-domain:
 domain 0: span 00000002
  groups: 00000002
  domain 1: span 00000002
   groups: 00000002
   domain 2: span 00000003
    groups: 00000002 00000001
Freeing unused kernel memory: 228k freed
input: AT Translated Set 2 keyboard on isa0060/serio0
SCSI subsystem initialized
Fusion MPT base driver 3.01.20
Copyright (c) 1999-2004 LSI Logic Corporation
ACPI: PCI Interrupt 0000:02:04.0[A] -> GSI 27 (level, low) -> IRQ 177
mptbase: Initiating ioc0 bringup
ioc0: 53C1030: Capabilities={Initiator}
Fusion MPT SCSI Host driver 3.01.20
scsi0 : ioc0: LSI53C1030, FwRev=01032300h, Ports=1, MaxQ=222, IRQ=177
  Vendor: SEAGATE   Model: ST336607LC        Rev: 0007
  Type:   Direct-Access                      ANSI SCSI revision: 03
SCSI device sda: 71687372 512-byte hdwr sectors (36704 MB)
SCSI device sda: drive cache: write back
SCSI device sda: 71687372 512-byte hdwr sectors (36704 MB)
SCSI device sda: drive cache: write back
 sda: sda1 sda2 sda3
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
  Vendor: HITACHI   Model: DK32EJ36NSUN36G   Rev: PQ08
  Type:   Direct-Access                      ANSI SCSI revision: 03
SCSI device sdb: 71132959 512-byte hdwr sectors (36420 MB)
SCSI device sdb: drive cache: write back
SCSI device sdb: 71132959 512-byte hdwr sectors (36420 MB)
SCSI device sdb: drive cache: write back
 sdb: sdb1 sdb2 sdb3
Attached scsi disk sdb at scsi0, channel 0, id 1, lun 0
device-mapper: 4.4.0-ioctl (2005-01-12) initialised: dm-devel@redhat.com
md: raid1 personality registered as nr 3
md: Autodetecting RAID arrays.
md: autorun ...
md: considering sdb2 ...
md:  adding sdb2 ...
md: sdb1 has different UUID to sdb2
md:  adding sda2 ...
...
continued booting...

Additional info:
Comment 1 Dave Jones 2005-10-02 17:02:12 EDT

*** This bug has been marked as a duplicate of 169610 ***

Note You need to log in before you can comment on or make changes to this bug.