Bug 169706 - SATA drive recognized as ATA; slow performance
SATA drive recognized as ATA; slow performance
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
: 169707 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-01 14:37 EDT by Thomas Roessler
Modified: 2013-07-02 22:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.14-1.1637_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-11 03:12:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/modprobe.conf (689 bytes, text/plain)
2005-10-03 03:02 EDT, Thomas Roessler
no flags Details

  None (edit)
Description Thomas Roessler 2005-10-01 14:37:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
2.6.13-1.1526 recognizes the hard drive in a Thinkpad T43 as an ATA drive (which, technically, it seems to be). Attempting to turn on the using_dma flag fails; the hard drive has a throughput of 3MB/s.

With prior Fedora Core kernels, the drive was recognized as an SATA drive, with about ten times the throughput.

Boot messages (1526):

Sep 30 09:44:10 lavazza kernel: ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
Sep 30 09:44:10 lavazza kernel: hda: HTS541040G9AT00, ATA DISK drive
Sep 30 09:44:10 lavazza kernel: hdc: HL-DT-STCD-RW/DVD DRIVE GCC-4242N, ATAPI CD/DVD-ROM drive
Sep 30 09:44:10 lavazza kernel: ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Sep 30 09:44:10 lavazza kernel: ide1 at 0x170-0x177,0x376 on irq 15
Sep 30 09:44:10 lavazza kernel: hda: max request size: 128KiB
Sep 30 09:44:10 lavazza kernel: hda: 78140160 sectors (40007 MB) w/7539KiB Cache, CHS=65535/16/63
Sep 30 09:44:10 lavazza kernel: hda: cache flushes supported
Sep 30 09:44:10 lavazza kernel:  hda: hda1 hda2
Sep 30 09:44:10 lavazza kernel: hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache

Boot messages (1398_FC4):

Sep 30 10:09:11 lavazza kernel: ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
Sep 30 10:09:11 lavazza kernel: ide0: I/O resource 0x1F0-0x1F7 not free.
Sep 30 10:09:11 lavazza kernel: ide0: ports already in use, skipping probe
Sep 30 10:09:11 lavazza kernel: hdc: HL-DT-STCD-RW/DVD DRIVE GCC-4242N, ATAPI CD/DVD-ROM drive
Sep 30 10:09:11 lavazza kernel: ide1 at 0x170-0x177,0x376 on irq 15
Sep 30 10:09:11 lavazza kernel: hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache
Sep 30 10:09:11 lavazza kernel: Uniform CD-ROM driver Revision: 3.20
Sep 30 10:09:11 lavazza kernel: ide-floppy driver 0.99.newide
...
Sep 30 10:09:12 lavazza kernel: SCSI subsystem initialized
Sep 30 10:09:12 lavazza kernel: ata: 0x170 IDE port busy
Sep 30 10:09:12 lavazza kernel: ata1: SATA max UDMA/133 cmd 0x1F0 ctl 0x3F6 bmdma 0x1810 irq 14
Sep 30 10:09:12 lavazza kernel: ata1: dev 0 ATA, max UDMA/100, 78140160 sectors:
Sep 30 10:09:12 lavazza kernel: ata1: dev 0 configured for UDMA/100
Sep 30 10:09:12 lavazza kernel: scsi0 : ata_piix
Sep 30 10:09:12 lavazza kernel:   Vendor: ATA       Model: HTS541040G9AT00   Rev: MB2I
Sep 30 10:09:12 lavazza kernel:   Type:   Direct-Access                      ANSI SCSI revision: 05
Sep 30 10:09:12 lavazza kernel: SCSI device sda: 78140160 512-byte hdwr sectors (40008 MB)
Sep 30 10:09:12 lavazza kernel: SCSI device sda: drive cache: write back
Sep 30 10:09:12 lavazza kernel: SCSI device sda: 78140160 512-byte hdwr sectors (40008 MB)
Sep 30 10:09:12 lavazza kernel: SCSI device sda: drive cache: write back
Sep 30 10:09:12 lavazza kernel:  sda: sda1 sda2
Sep 30 10:09:12 lavazza kernel: Attached scsi disk sda at scsi0, channel 0, id 0, lun 0

# lspci
00:00.0 Host bridge: Intel Corporation Mobile 915GM/PM/GMS/910GML Express Processor to DRAM Controller (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
00:1d.3 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev d3)
00:1e.2 Multimedia audio controller: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
00:1e.3 Modem: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)
00:1f.0 ISA bridge: Intel Corporation 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
00:1f.2 IDE interface: Intel Corporation 82801FBM (ICH6M) SATA Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751M Gigabit Ethernet PCI Express (rev 11)
04:00.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
04:02.0 Network controller: Intel Corporation: Unknown device 4224 (rev 05)


Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1526_FC4

How reproducible:
Always

Steps to Reproduce:
boot.

Actual Results:  slow hard disk

Expected Results:  fast hard disk

Additional info:
Comment 1 Thomas Roessler 2005-10-01 14:42:30 EDT
*** Bug 169707 has been marked as a duplicate of this bug. ***
Comment 2 Thomas Roessler 2005-10-01 17:56:35 EDT
I'm wondering if this is the same problem as bug 169691.
Comment 3 Dave Jones 2005-10-02 17:19:40 EDT
what does your /etc/modprobe.conf look like ?
Comment 4 Thomas Roessler 2005-10-03 03:02:58 EDT
Created attachment 119526 [details]
/etc/modprobe.conf

Here you go...
Comment 5 Thomas Roessler 2005-10-04 04:25:03 EDT
Booting with hda=noprobe (as suggested as a rememdy for 169691) seems to fix
this problem.
Comment 6 Dave Jones 2005-11-10 14:21:59 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.