Bug 169719 - madvise returns EBADF for anonymous mappings
madvise returns EBADF for anonymous mappings
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-01 21:27 EDT by dtc-rhbug
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.14-1.1637_FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-10 19:03:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example test code. (262 bytes, text/plain)
2005-10-01 21:31 EDT, dtc-rhbug
no flags Details

  None (edit)
Description dtc-rhbug 2005-10-01 21:27:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
The madvise system call is returning an EBADF error for anonymous
mappings.  This is due to a recently introduced change to always
return EBADF if not associated with a file.  This interpretation of
madvise may not be correct.  Allowing madvise to operate on anonymous
mappings can be useful for improving performance on some applications.
Works on Solaris.


Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1526_FC4

How reproducible:
Always

Steps to Reproduce:
1. Compile and run the attached program.
2.
3.
  

Actual Results:  The madvise system call returns an EBADF error.

Expected Results:  The madvise system call should succeed.

Additional info:
Comment 1 dtc-rhbug 2005-10-01 21:31:07 EDT
Created attachment 119513 [details]
Example test code.
Comment 2 dtc-rhbug 2005-10-11 12:06:38 EDT
A kernel patch has been approved reverting the change in
behavior the system call.  This patch should be picked up
in due course and will resolve this issue.
Comment 3 Dave Jones 2005-11-10 14:37:09 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 4 dtc-rhbug 2005-11-10 19:03:59 EST
The issue is resolved by kernel-2.6.14-1.1637_FC4.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.