Bug 16978 - Charset changes non-effective
Charset changes non-effective
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: links (Show other bugs)
1.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
: 24459 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-25 22:10 EDT by Michal Jaegermann
Modified: 2007-04-18 12:28 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-02 11:02:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Compressed html file which is using koi8-r encoding (1.49 KB, application/octet-stream)
2000-08-25 22:12 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2000-08-25 22:10:36 EDT
In an environment with properly sets fonts (in this particular
case lucidatypewriter in koi8-r encoding on gnome-terminal)
'cat', 'less', 'lynx' (and also 'netscape') will show up attached
text in a legible form but 'links' insists on using iso8859-1
encoding.  An explicit change of a language and character set
in a "Setup" menu does change a font and strings used for menus (!!)
but leaves text viewed useless and there is no apparent way
to change that.

I attach an html file from a Russian site which demonstrated the
problem.

  Michal
Comment 1 Michal Jaegermann 2000-08-25 22:12:30 EDT
Created attachment 3018 [details]
Compressed html file which is using koi8-r encoding
Comment 2 Michal Jaegermann 2000-08-25 22:20:39 EDT
For a more fun setting a character set to koi8-r, and back to iso 8859-1
(but not to iso 8859-2) makes the text suddenly readable although
assumed code page did not change at all.
Comment 3 Henri Schlereth 2001-01-20 04:30:51 EST
This bug is from the previous beta-cycle. If this problem still exists please re-open it under beta-2 (Florence)
Comment 4 Michal Jaegermann 2001-01-20 13:13:56 EST
Despite of "resolved and closed" status a behaviour remains exactly like
described in the original report.  Explicit changes of LANG are not effective.
Resubmitted for Florence beta2 as #24459.
Comment 5 Bernhard Rosenkraenzer 2001-01-20 13:14:31 EST
*** Bug 24459 has been marked as a duplicate of this bug. ***
Comment 6 Bernhard Rosenkraenzer 2001-01-20 13:17:16 EST
Bug report sent to base package maintainer; maybe he has the time to fix this
before I do.

Note You need to log in before you can comment on or make changes to this bug.