Bug 169790 - Can not connect to ms exchange server from x86_64 machine
Can not connect to ms exchange server from x86_64 machine
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: evolution-connector (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: Desktop
Depends On:
Blocks: 170416
  Show dependency treegraph
 
Reported: 2005-10-03 12:45 EDT by Wes Armour
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-21 10:53:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wes Armour 2005-10-03 12:45:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
My home area is mounted from a central server via nfs.
I can use evolution to connect to my my exchange mailbox on any 32 bit machine that I log on to. 
When I try to launch evolution on a 64 bit machine...

setting the debug level: 
export E2K_DEBUG=4

launching evolution-exchange-storage:
/usr/libexec/evolution/2.0/evolution-exchange-storage &

returns:
(evolution-exchange-storage:10528): evolution-exchange-storage-WARNING **: Bad socket dir /tmp/.exchange-wa78

launching evolution:
evolution &

returns:
Error while Scanning folders in "Exchange server foo".
Could not connect to Evolution Exchange backend process: Permission denied.

The debug shows:
(evolution:10540): evolution-shell-WARNING **: Cannot activate 'OAFIID:GNOME_Evolution_Exchange_Component:2.0': Child process did not give an error message, unknown failure occurred


(evolution:10540): camel-WARNING **: Cannot load summary file: `/home/wa78/.evolution/mail/local/Inbox.ev-summary': No such file or directory

(evolution:10540): camel-WARNING **: Invalid root: '/home/wa78/.evolution/mail/local/Drafts.ibex.index'

(evolution:10540): camel-WARNING **: version: TEXT.000 (TEXT.000)

(evolution:10540): camel-WARNING **: block size: 1024 (1024) OK

(evolution:10540): camel-WARNING **: free: 0 (0 add size < 1024) OK

(evolution:10540): camel-WARNING **: last: 6144 (6144 and size: 1024) BAD

(evolution:10540): camel-WARNING **: flags: unSYNC

(evolution:10540): camel-WARNING **: Cannot load summary file: `/home/wa78/.evolution/mail/local/Outbox.ev-summary': No such file or directory
loading error file /usr/share/evolution/2.0/errors/addressbook-errors.xml
loading error file /usr/share/evolution/2.0/errors/filter-errors.xml
loading error file /usr/share/evolution/2.0/errors/mail-errors.xml
loading error file /usr/share/evolution/2.0/errors/e-system-errors.xml
loading error file /usr/share/evolution/2.0/errors/shell-errors.xml
loading error file /usr/share/evolution/2.0/errors/mail-composer-errors.xml
loading error file /usr/share/evolution/2.0/errors/calendar-errors.xml

I have the following installed on my 64 bit machine:
evolution-data-server-1.0.2-7
evolution-webcal-1.0.10-1
evolution-data-server-1.0.2-7
evolution-connector-2.0.2-5
evolution-2.0.2-16.3

When I try to remove the i386 version of evolution-data-server I get:
error: Failed dependencies:
        libebook.so.8 is needed by (installed) openoffice.org-1.1.2-24.6.0.EL4.i386
        libedataserver.so.3 is needed by (installed) openoffice.org-1.1.2-24.6.0.EL4.i386

Thanks,

Wes.

Version-Release number of selected component (if applicable):
evolution-connector-2.0.2-5

How reproducible:
Always

Steps to Reproduce:
See above

Actual Results:  can not see exchange server

Expected Results:  be able to browse my e-mails

Additional info:
Comment 1 Dave Malcolm 2005-10-06 18:39:37 EDT
Thanks for this bug report.

Please can you specify the result of running thesse commands on the x86_64 machine:

rpm --qf "%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH}\n" -q evolution
evolution-data-server libgal2 libsoup evolution-connector evolution-webcal
openoffice.org

ls -alZ /tmp/.exchange-wa78

Thanks.

This appears to be a separate issue, but I should point out that there is a bug
(filed as bug 166627) with 64-bit cleanliness in the NTLM authentication code in
the RHEL4 libsoup and evolution-connector packages, which will cause problems at
random if you're using NLTM (listed as "Secure Password" in Evolution's UI, and
as Integrated Windows Authentication in the server's IIS UI, IIRC).  Sometimes
it will work, but at other times, at random, it will fail with a "Password
incorrect?" error dialog.  

I'm working on getting this fix into the next RHEL update.  In the meantime, you
may want to try these test packages which contain the NTLM fix for x86_64:
http://people.redhat.com/dmalcolm/scratch/libsoup-2.2.1-2.fix166627.1.x86_64.rpm
http://people.redhat.com/dmalcolm/scratch/evolution-connector-2.0.2-8.fix166627.1.x86_64.rpm
(though these are not "officially supported" at this time)

Comment 3 Wes Armour 2005-10-28 04:54:47 EDT
Hi 

I get:

[wa78@pc007 ~]$ rpm --qf "%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH}\n" -q evolution
evolution-data-server libgal2 libsoup evolution-connector evolution-webcal
openoffice.org
evolution-2.0.2-16.3-x86_64
evolution-data-server-1.0.2-7-x86_64
evolution-data-server-1.0.2-7-i386
libgal2-2.2.3-4-x86_64
libsoup-2.2.1-1-i386
libsoup-2.2.1-1-x86_64
evolution-connector-2.0.2-5-x86_64
evolution-webcal-1.0.10-1-x86_64
openoffice.org-1.1.2-24.6.0.EL4-i386

and on the 64 bit machine (not running evolution at the time):

[wa78@pc007 ~]$ ls -alZ /tmp/.exchange-wa78
ls: /tmp/.exchange-wa78: Permission denied

On the 32bit machine running evolution:

[wa78@diamrl5001 ~]$ ls -alZ /tmp/.exchange-wa78
drwx------  wa78     wa78     user_u:object_r:tmp_t            .
drwxrwxrwt  root     root     system_u:object_r:tmp_t          ..
srwxrwxr-x  wa78     wa78     user_u:object_r:tmp_t           
wa78@exchange33.rl.ac.uk


Thanks,

Wes.

Comment 4 Dave Malcolm 2005-10-28 17:09:04 EDT
Thanks for the updated information.  It look like an SELinux-related problem. 
Are you running the strict or targeted policy?

What's the result of running "ls -alZ /tmp/" on the 64-bit machine?

If you're not in a production environment, what happens if you disable
enforcement of SELinux's protection (by running "setenforce 0" as root) and then
retry?  If it's not safe to do that, we can try another approach.

(I suspect you may also be running into bug 166627 as discussed above in comment 1)

I should also mention that issues that come in through bugzilla are by necessity
a lower priority item on my task list than requests through Red Hat Support. 
I'm currently working on various other bugs.  If I'm underestimating the pain
that this bug is causing you, please contact Red Hat Support and we can
reprioritise and reassign as appropriate.  Thanks.
Comment 5 Wes Armour 2005-11-07 11:23:47 EST
"ls -alZ /tmp/" on the 64-bit machine:

[wa78@pc007 rhn]$ ls -alZ /tmp/
drwxrwxrwt  root     root     system_u:object_r:tmp_t          .
drwxr-xr-x  root     root     system_u:object_r:root_t         ..
drwx------  oracle   500      user_u:object_r:tmp_t            .exchange-wa78
drwxrwxrwt  root     root     user_u:object_r:initrc_tmp_t     .font-unix
drwx------  wa78     wa78     user_u:object_r:tmp_t            gconfd-wa78
-rw-------  wa78     wa78     user_u:object_r:initrc_tmp_t     .gdm4zD1Ri
-rw-------  wa78     wa78     user_u:object_r:tmp_t            .gdmEdgM6d
-rw-------  wa78     wa78     user_u:object_r:initrc_tmp_t     .gdmj7T2Xt
srw-rw-rw-  root     root     user_u:object_r:initrc_tmp_t     .gdm_socket
drwxrwxrwt  root     root     user_u:object_r:initrc_tmp_t     .ICE-unix
drwx------  wa78     wa78     user_u:object_r:tmp_t            keyring-wgkLqi
-rw-------  wa78     wa78     user_u:object_r:tmp_t            krb5cc_37028_Cdba
                                                                               
                                                
zG
-rw-------  wa78     wa78     user_u:object_r:initrc_tmp_t     krb5cc_37028_Tvj6
                                                                               
                                                
Ur
srwxr-xr-x  root     root     root:object_r:tmp_t              mapping-root
srwxrwxr-x  wa78     wa78     user_u:object_r:tmp_t            mapping-wa78
drwx------  wa78     wa78     user_u:object_r:tmp_t            mcop-wa78
drwx------  wa78     wa78     user_u:object_r:tmp_t            orbit-wa78
drwx------  wa78     wa78     user_u:object_r:tmp_t            ssh-FBFWps4083
-r--r--r--  root     root     user_u:object_r:initrc_tmp_t     .X0-lock
drwxrwxrwt  root     root     user_u:object_r:initrc_tmp_t     .X11-unix
-rw-------  wa78     wa78     user_u:object_r:tmp_t            xses-wa78.MEQ8La
-rw-------  wa78     wa78     user_u:object_r:initrc_tmp_t     xses-wa78.MhCGLE

disable enforcement of SELinux's protection:

[wa78@pc007 rhn]$ ls -alZ /tmp/
drwxrwxrwt  root     root     system_u:object_r:tmp_t          .
drwxr-xr-x  root     root     system_u:object_r:root_t         ..
drwx------  oracle   500      user_u:object_r:tmp_t            .exchange-wa78
drwxrwxrwt  root     root     user_u:object_r:initrc_tmp_t     .font-unix
drwx------  wa78     wa78     user_u:object_r:tmp_t            gconfd-wa78
-rw-------  wa78     wa78     user_u:object_r:initrc_tmp_t     .gdm4zD1Ri
-rw-------  wa78     wa78     user_u:object_r:tmp_t            .gdmEdgM6d
-rw-------  wa78     wa78     user_u:object_r:initrc_tmp_t     .gdmj7T2Xt
srw-rw-rw-  root     root     user_u:object_r:initrc_tmp_t     .gdm_socket
drwxrwxrwt  root     root     user_u:object_r:initrc_tmp_t     .ICE-unix
drwx------  wa78     wa78     user_u:object_r:tmp_t            keyring-wgkLqi
-rw-------  wa78     wa78     user_u:object_r:tmp_t            krb5cc_37028_CdbazG
-rw-------  wa78     wa78     user_u:object_r:initrc_tmp_t     krb5cc_37028_Tvj6Ur
srwxr-xr-x  root     root     root:object_r:tmp_t              mapping-root
srwxrwxr-x  wa78     wa78     user_u:object_r:tmp_t            mapping-wa78
drwx------  wa78     wa78     user_u:object_r:tmp_t            mcop-wa78
drwx------  wa78     wa78     user_u:object_r:tmp_t            orbit-wa78
drwx------  wa78     wa78     user_u:object_r:tmp_t            ssh-FBFWps4083
-r--r--r--  root     root     user_u:object_r:initrc_tmp_t     .X0-lock
drwxrwxrwt  root     root     user_u:object_r:initrc_tmp_t     .X11-unix
-rw-------  wa78     wa78     user_u:object_r:tmp_t            xses-wa78.MEQ8La
-rw-------  wa78     wa78     user_u:object_r:initrc_tmp_t     xses-wa78.MhCGLE

and 
[wa78@pc007 rhn]$ ls -alZ /tmp/.exchange-wa78/
ls: /tmp/.exchange-wa78/: Permission denied

I did a 

chown wa78:wa78 /tmp/.exchange-wa78/

And now it works!!!

I'm guessing that at some point I looked at my mail using a local machine
account that has a different uid to my network account???

One thing I have noticed is that I need to look in a folder twice before I
actually see the contents. Also I seem to have to enter my password atleast
twice each time I connect to the exchange server???? I think that there is
something strange going on with the local caching of folders as well because
some of the folders report that there are unread e-mails in them and when I
enter the folders they refresh and report things correctly. (my home account is
nfs mounted from a central server).

Thanks,

Wes.
Comment 10 RHEL Product and Program Management 2006-07-21 10:53:53 EDT
Development Management has reviewed and declined this request.  You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.