Bug 169825 - Forgot hit space with Canjie and it will be crash.
Forgot hit space with Canjie and it will be crash.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: iiimf-le-xcin (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Leon Ho
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-04 03:58 EDT by Tina
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-13 00:39:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tina 2005-10-04 03:58:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; zh-TW; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When using Canjie under both iiimf-le-xcin-0.1.10-1 and
iiimf-le-xcin-0.1.10-2, the input method crashes whenever I forget to hit
space before inputing for the next character. When it happens, I need to
login again X window to restart the input method.

Is it a bug? 

Version-Release number of selected component (if applicable):
iiimf-le-xcin-0.1.10-2

How reproducible:
Sometimes

Steps to Reproduce:
1.Switching in Canjie IM.
2.Fogrot to hit space before inputing for the next character. (sometimes will be crashed)
3.Need to login again X window to restart the input method.

  

Additional info:
Comment 1 Leon Ho 2005-10-12 00:09:54 EDT
I cannot reproduce it. What characters did you type? Would you give me a key
sequence example? Thanks!
Comment 2 Tina 2005-10-18 23:03:21 EDT
Hi,

Here's an example:

If I want to type '中華民國', the keys for these four characters are:
中, 廿一廿十, 口女心, 田戈口一

Everytime I finish typng the keys for one character, I need to hit space so
that the character will come out. But if I forget to hit space or I hit it too
slightly, the input method may crash (not everytime).

Besides, I didn't explain clearly last time that I need to restart the machine
instead of re-login to have the input method back.

Thanks, 
Comment 3 Leon Ho 2006-07-13 00:39:03 EDT
Still cannot reproduce it. Please try the latest IM in FC5 and see if it helps.

Note You need to log in before you can comment on or make changes to this bug.