Bug 169841 - Another crash in nscd_getpw_r()
Another crash in nscd_getpw_r()
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-04 08:15 EDT by Piotr Gackiewicz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-07 12:17:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
valgrind output (13.12 KB, text/plain)
2005-10-04 08:41 EDT, Piotr Gackiewicz
no flags Details

  None (edit)
Description Piotr Gackiewicz 2005-10-04 08:15:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050912 Fedora/1.0.6-1.2.fc3 Firefox/1.0.6

Description of problem:
Lots of getpwnam() with nscd running crashes perl.


Version-Release number of selected component (if applicable):
glibc-2.3.5-10.3+patch from closed bug 169813

How reproducible:
Always

Steps to Reproduce:
1.perl -e 'while(1) { getpwnam("gacek"); }'
2.wait several minutes for segfault


Actual Results:  perl segfaults

Expected Results:  no segfault

Additional info:

valgrind output in attachment
Comment 1 Piotr Gackiewicz 2005-10-04 08:41:23 EDT
Created attachment 119587 [details]
valgrind output
Comment 2 Ulrich Drepper 2005-11-08 20:13:17 EST
Try the current rawhide glibc and see whether you can reproduce it there.
Comment 3 Jakub Jelinek 2006-01-07 12:17:53 EST
Please reopen if/once you try current rawhide.  I couldn't reproduce this.

Note You need to log in before you can comment on or make changes to this bug.