Bug 169842 - "short" accessed as a 32-bit word with -O1
"short" accessed as a 32-bit word with -O1
Status: CLOSED DUPLICATE of bug 169845
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc (Show other bugs)
3.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks: 169792
  Show dependency treegraph
 
Reported: 2005-10-04 08:59 EDT by Miloslav Trmač
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-04 09:05:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Simplified reproducer (293 bytes, text/plain)
2005-10-04 09:00 EDT, Miloslav Trmač
no flags Details

  None (edit)
Description Miloslav Trmač 2005-10-04 08:59:28 EDT
Description of problem:
The attached test case (derived from doset () in sh.set.c from tcsh)
should read "val = *ptr" using a 16-bit read, but it uses a 32-bit read.
When *ptr is located at end of a page, this can cause a SIGSEGV.

Version-Release number of selected component (if applicable):
gcc-3.2.3-53

How reproducible:
gcc -S -O1 foo2.c && less foo2.s

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Miloslav Trmač 2005-10-04 09:00:15 EDT
Created attachment 119592 [details]
Simplified reproducer
Comment 2 Miloslav Trmač 2005-10-04 09:05:16 EDT
Oops, sorry about the dupes.

*** This bug has been marked as a duplicate of 169845 ***

Note You need to log in before you can comment on or make changes to this bug.