This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 169852 - kernel don't manages the intel sata IDE controller
kernel don't manages the intel sata IDE controller
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Garzik
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-04 09:51 EDT by fv3358
Modified: 2013-07-02 22:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-04 19:54:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description fv3358 2005-10-04 09:51:29 EDT
Description of problem:
When booting the system, the kernel boots and checks a lot of devices, but it
can't mount the "/" partition.

Version-Release number of selected component (if applicable):

kernel 2.6.13-1.1526__FC4

How reproducible:
Installing the kernel and booting with it.

Steps to Reproduce:
1. Install kernel 2.6.13-1.1526_FC4
2. Boot the system with this kernel
3.
  
Actual results:
kernel panic. Can't mount the reiserfs "/" partition

Expected results:
normal boot of the system, like with the previous kernel.

Additional info:

IDE controler:
00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) SATA Controller (rev 02)

My box has only one SATA disk, and one DVD unit. No normal ATA disks are
connected. I think it's a problem with the ata_piix controller. With the
previous kernel it worked right
Comment 1 fv3358 2005-10-05 13:53:05 EDT
Manual transcription of the screen output during boot:

ata: 0x1f0 IDE port busy
ata: 0x170 IDE port busy
ata_piix: probe of 000:00:1f.2 failed with error -16

Loading reiserfs.ko module
Creating root device
Mounting root filesystem
mount: error 6 mounting reiserfs
Comment 2 Dave Jones 2005-10-06 03:44:22 EDT
booting with hda=noprobe should work around this for now
Comment 3 fv3358 2005-10-06 13:21:20 EDT
Yes, booting with hda=noprobe the kernel booted right
Comment 4 Charlie Bennett 2005-10-14 11:31:43 EDT
is there a fix on the way?  I've got racks full of Dells that have this problem

Thanks,
ccb
Comment 5 winproof 2005-10-14 11:58:26 EDT
Hello,
same problem for a lot of GX620, with the 2.6.12-1.1378_FC3, no news?
Thanks
Comment 6 Phil Lembo 2005-11-04 10:50:17 EST
Additional report:

Running FC3 (kernel 2.6.9-1.667.i386 on Dell GX620 with SATA set to
"Combination" mode. Unable to upgrade kernel because results in panic on reboot.
System complains that ide ports already in use.

Same result with 2.6.12-1.1381_FC3.i686 kernel. hda=noprobe does not help.

Unable to try 2.6.10 or 2.6.11 because no archive available for those series.

Comment 7 Dave Jones 2005-11-04 19:54:02 EST
2.6.13-1.1532_FC4 should have this fixed.
Comment 8 fv3358 2005-11-05 01:32:36 EST
Yes, with the 2.6.13-1.1532_FC4 kernel, the problem is fixed

Note You need to log in before you can comment on or make changes to this bug.