Bug 169867 - udev doesn't start on boot, can be started later
udev doesn't start on boot, can be started later
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-04 11:53 EDT by Horst H. von Brand
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.69-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-13 13:31:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2005-10-04 11:53:44 EDT
Description of problem:
On booting x86_64 (fully up-to-date rwahide) starting udev takes a /long/time
and fails. Letting the machine boot and starting udev by hand (start_udev) gives
a working udev.

Version-Release number of selected component (if applicable):
udev-0.69-6

How reproducible:
Always

Steps to Reproduce:
1. Boot
2.
3.
  
Actual results:
udev start fails, no X (because of missing /dev/mem), ...
Once booted, start_udev returns immediately, and the missing nodes are created.

Expected results:
Normal boot

Additional info:
The very same setup has failed for several udev versions, I did not dig deeper
until today. On i386 it works fine.
Comment 1 Harald Hoyer 2005-10-13 07:16:14 EDT
does udev-0.69-10 fix the problem?
Comment 2 Horst H. von Brand 2005-10-13 13:31:49 EDT
Yes, sorry for the delay. I believe it was fixed in udev-0.69-9

Note You need to log in before you can comment on or make changes to this bug.