Bug 169870 - ppp_generic: Unknown symbol
ppp_generic: Unknown symbol
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-04 11:58 EDT by Kevin Graff
Modified: 2015-01-04 17:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 12:19:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Graff 2005-10-04 11:58:19 EDT
Oct  4 08:44:19 laptop kernel: Linux version 2.6.13-1.1526_FC4
(bhcompile@hs20-bc1-6.build.redhat.com) (gcc version 4.0.1 20050727 (Red Hat
4.0.1-5)) #1 Wed Sep 28 19:15:10 EDT 2005

when loading mod ppp_generic I get the following error

Oct  4 08:44:37 laptop kernel: ppp_generic: Unknown symbol class_simple_device_add
Oct  4 08:44:37 laptop kernel: ppp_generic: Unknown symbol class_simple_destroy
Oct  4 08:44:37 laptop kernel: ppp_generic: Unknown symbol
class_simple_device_remove
Oct  4 08:44:37 laptop kernel: ppp_generic: Unknown symbol class_simple_create

I get the smae error on 3 diffrent computers

kevin@buffalowelding.com
Comment 1 Gavin Dodds 2005-10-08 08:49:04 EDT
I see the same errors after upgrading to kernel 2.6.13-1.1526_FC4, reverting to
2.6.12-1.1456_FC4 removes the issue.
Comment 2 Lukas Middendorf 2005-10-14 09:00:11 EDT
If I run ifup for my ppoe-adsl-connection on 2.6.13-1.1526_FC4 and 2.6.13-1.
1526_FC4smp the script fails after about a minute with the message "/sbin/adsl-
start: line 217:  4415 Terminated              $CONNECT "$@" >/dev/null 2>&1§


Looking at /var/log/messages shows the following errors:

Oct 14 14:23:00 lukas kernel: ppp_generic: Unknown symbol 
class_simple_device_add
Oct 14 14:23:00 lukas kernel: ppp_generic: Unknown symbol class_simple_destroy
Oct 14 14:23:00 lukas kernel: ppp_generic: Unknown symbol 
class_simple_device_remove
Oct 14 14:23:00 lukas kernel: ppp_generic: Unknown symbol class_simple_create
Oct 14 14:23:00 lukas kernel: ppp_generic: Unknown symbol 
class_simple_device_add
Oct 14 14:23:00 lukas kernel: ppp_generic: Unknown symbol class_simple_destroy
Oct 14 14:23:00 lukas kernel: ppp_generic: Unknown symbol 
class_simple_device_remove
Oct 14 14:23:00 lukas kernel: ppp_generic: Unknown symbol class_simple_create
Oct 14 14:23:00 lukas kernel: ppp_async: Unknown symbol ppp_channel_index
Oct 14 14:23:00 lukas kernel: ppp_async: Unknown symbol ppp_register_channel
Oct 14 14:23:00 lukas kernel: ppp_async: Unknown symbol ppp_input
Oct 14 14:23:00 lukas kernel: ppp_async: Unknown symbol ppp_input_error
Oct 14 14:23:00 lukas kernel: ppp_async: Unknown symbol ppp_output_wakeup
Oct 14 14:23:00 lukas kernel: ppp_async: Unknown symbol ppp_unregister_channel
Oct 14 14:23:00 lukas kernel: ppp_async: Unknown symbol ppp_unit_number
Oct 14 14:23:00 lukas modprobe: FATAL: Error inserting ppp_generic (/lib/
modules/2.6.13-1.1526_FC4smp/kernel/drivers/net/ppp_generic.ko): Unknown symbol 
in module, or unknown parameter (see dmesg) 
Oct 14 14:23:00 lukas pppd[4441]: This system lacks kernel support for PPP.  
This could be because the PPP kernel module could not be loaded, or because PPP 
was not included in the kernel configuration.  If PPP was included as a module, 
try `/sbin/modprobe -v ppp'.  If that fails, check that ppp.o exists in /lib/
modules/`uname -r`/net. See README.linux file in the ppp distribution for more 
details. 
Oct 14 14:23:00 lukas adsl-connect: ADSL connection lost; attempting re-
connection.

These messages repeat several times in different order.

I use 2.6.12-1.1456 again because everything is OK with this kernel.
Comment 3 Lukas Middendorf 2005-10-23 08:38:51 EDT
The same problem still exists with 2.6.13-1.1532_FC4
Comment 4 Thomas Woerner 2005-10-24 06:59:02 EDT
This is a kernel module problem, not a pppd userland problem.
Assigning to kernel.
Comment 5 Dave Jones 2005-10-25 04:53:29 EDT
modprobe ppp-generic works just fine for me.

are you using the stock ppp modules that come with that kernel ?

The reason I ask, is that the symbols it can't load don't occur in the kernel
tree at all any more.  It's almost as if you're loading an old version of ppp
into a new kernel.
Comment 6 Lukas Middendorf 2005-10-25 08:34:06 EDT
Sorry, it was my fault. It was the dkms autoinstaller replacing ppp_generic.ko 
when installing kernel_ppp_mppe. I didn't know that before, but when 
uninstalling it, the uninstaller said, it copied back the original ppp_generic.
ko.
I removed dkms and kernel_ppp_mppe (I don't need them anymore) and now 
everything works fine.
Comment 7 Kevin Graff 2005-10-25 10:58:10 EDT
I also was using dkms and kernel_ppp_mppe. Sorry for the bug report. But I do
need   
ppp_mppe for work.  Can anyone tell me if there is a fix or where to report the
trouble with ppp_mppe?
Comment 8 Kevin Graff 2005-10-25 12:19:08 EDT
I upgraded to kernel_ppp_mppe-1.0.2-3dkms and no longer have any trouble.

Note You need to log in before you can comment on or make changes to this bug.