Bug 16988 - Signal 11 on HP Netserver 5/100 LC
Signal 11 on HP Netserver 5/100 LC
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-26 14:01 EDT by bhartin
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-24 12:10:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bhartin 2000-08-26 14:01:12 EDT
Following text appears when running install:

"Running anaconda - may take some time to load..."
"install exited abnormally -- recieved signal 11"

On console 3, the last message is:

"* looking for USB mouse..."

Relevant system details:

Hewlett Packard NetServer 5/100 LC
Pentium 133
32 MB ECC SIMMs
Embedded Adaptec AIC7770 SCSI controller
PS/2 Keyboard
PS/2 Mouse
No USB at all on this system
No serial devices on this system

Further details available at request.

Install was from a SCSI CD-ROM created with "pinstripe-en-i386-cd1.iso"
Comment 1 bhartin 2000-08-26 19:53:29 EDT
I ran through a few other distributions on the same server, hopefully to work
around the bug:

Redhat Pinstripe FTP inst 
  - Same as CD install
  - I only ran this in case the regular files were updated as opposed
    to the ISO file I used
  - Had to run in Expert mode to load AIC7770 driver.
Redhat 6.2 FTP inst - 
  - AIC7770 driver in this kernel version has a bug, panics
  - Had to run in Expert mode to load AIC7770 driver.
Redhat 6.1 CD inst -
  - "install exited abnormally -- recieved signal 11".
  - Message given while "Reading package information..." is on screen
Redhat 6.0 FTP inst -
  - Same as 6.1 CD install
Comment 2 Michael Fulbright 2000-08-29 12:24:08 EDT
Have you tried a text mode install?
Comment 3 bhartin 2000-08-29 18:31:03 EDT
Yes, I've only been doing text mode (text, expert, and text expert) installs, as
a graphical mode install results in the machine rebooting itself (Mandrake's
graphical install doesn't do this, just for reference).
Comment 4 Joe Ceklosky 2000-08-30 08:31:06 EDT
This sounds like my problem too.  I am seeing the anaconda installer SEGV due to the kernel being unable to
handle a page request.  The MEMORY IS FINE in the machine Redhat 6.2 and kernel compiles are perfect.
This bug in anaconda started to appear in Redhat 6.2 and Pinstripe. 

I was using text install.  

I tried the latest Rawhide and the BUG IS STILL there.

BUG  # 15385


Comment 5 Michael Fulbright 2000-08-30 12:36:56 EDT
You can try running the installer with the 'nousb' to see if that helps.
Comment 6 bhartin 2000-08-30 18:55:50 EDT
Same results, install run as "text nousb".

1) Gives message about starting Anaconda...
2) Last message displayed on console 3 is:
   * going to insmod ext3.o (path is NULL)
3) After this message, the system pauses about 45 seconds before it
gives the signal 11 message and shuts down.
Comment 7 Joe Ceklosky 2000-08-30 20:57:54 EDT
Even with nousb the installer SEGVs while installing the packages.

Comment 8 Michael Fulbright 2000-10-04 12:55:24 EDT
This sounds like a problem particular to your hardware, as we haven't seen this
problem in our testing on a wide array of configurations.

You could also try an expert mode install and see if that helps - it does less
probing of your hardware.
Comment 9 bhartin 2000-10-04 13:49:46 EDT
As stated before, I have been attempting expert installs.  Specifically, I've
usually tried "text expert nousb".

So far, I have tried Redhat 7.0, 6.9.5, 6.2, 6.1, 6.0, and 5.2.  I've also tried
Mandrake 7, and finally Debian 2.2.  The furthest I got with any Linux distro
was with Debian, with it failing on formatting the drives (due to outdated
AIC-7770 drivers).

The machine was previously running SCO Openserver 5, and is now running FreeBSD
4.1.1.  So far those are the only things I can get successfully and completely
installed.  I don't know if this will help any, but due to "bugs" in FreeBSD, I
have to install it with options to force it to probe up to 12 EISA slots rather
than it's default number, in order to see the on-board Adaptec.  I've also had
issues getting any NICs to run on this due to the inability to turn off any bios
"PNP OS" settings (the netserver has no such options), but this is also due to a
bug in FreeBSD's PCI PNP handling.

I'm still open to providing whatever I can to get Redhat running on here...I
have no experience with FreeBSD, and while I'm interested in it purely for the
experience, I'd much rather have Linux running on it.
Comment 10 Michael Fulbright 2000-10-24 12:10:44 EDT
EISA systems are not supported.  There just are not enough left for community
members to work on 
them, and new systems do not ship with it (haven't for awhile).

Note You need to log in before you can comment on or make changes to this bug.