Bug 16994 - UDP packets queue problem
Summary: UDP packets queue problem
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Alan Cox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-26 21:46 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-15 17:53:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-08-26 21:46:29 UTC
During hevy load of UDP packaging, after having certain amount of
bytes on a listen queue of certain port, the listening
server starts to receiving malformed packets. Giving the message:Bad arg 
length for Socket, during a recv system call. The message stops as soon
as the queue reach 0 lenght again, it starts again as the lenght size
growns.

It is a really serius problem because it can put out of service
something as important as radius service.

Comment 1 Alan Cox 2000-09-15 17:53:51 UTC
Do you have a simple demonstration piece of code that shows this. I can't
generate this 
behaviour.



Note You need to log in before you can comment on or make changes to this bug.