Bug 169949 - Mouse cursor disappears in Toshiba Portege Laptop after display is switched to external monitor or LCD projector
Mouse cursor disappears in Toshiba Portege Laptop after display is switched t...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 169950 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-05 13:01 EDT by Mahendra M
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-12 01:31:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mahendra M 2005-10-05 13:01:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I have a Toshiba Portege laptop. All ACPI stuff works fine in kernel 2.6.12-1.1398_FC4. I used the fnfx ( http://fnfx.sf.net ) daemon that came with FC4 for Fn keys.

Recently, I upgraded to kernel 2.6.13-1.1526_FC4. Now, when I switch the display to an external monitor or LCD projector and switch back, the cursor disappears.

I have a simple USB optical mouse and a Synaptics Touchpad,

Mouse :
 usb 2-1: new low speed USB device using uhci_hcd and address 2
 input: USB HID v1.10 Mouse [USB_PS2 Optical Mouse] on usb-0000:00:1d.0-1

Touchpad :
 model: 1, fw: 6.2, id: 0x88a0b1, caps: 0xa04713/0x0

The cursor disappears completely. However, when I move my mouse, icons get highlighted ( as if the cursor is over them ). On double clicking, the icons work. This means that the driver and device is working fine. Only the cursor is missing.

I am also running xorg-x11 version 6.8.2, release 37.FC4.49.2

Regards,
Mahendra


Version-Release number of selected component (if applicable):
kernel-2.6.13-1.1526_FC4

How reproducible:
Always

Steps to Reproduce:
1.Switch the display to an external monitor or LCD projector
2.Move the mouse
3.The cursor would have disappeared.

Actual Results:  The mouse cursor disappears.

Expected Results:  The mouse cursor should have been on screen.

Additional info:
Comment 1 Dave Jones 2005-10-06 03:38:52 EDT
*** Bug 169950 has been marked as a duplicate of this bug. ***
Comment 2 Dave Jones 2005-11-10 14:49:28 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 3 Mahendra M 2005-11-11 11:46:06 EST
The problem seems to have been fixed in 2.6.14-1.1637_FC4

A lot of other issues with ACPI also seem to have been fixed. The stuff is
working really well.

Thanks a lot.

Regards,
Mahendra

Note You need to log in before you can comment on or make changes to this bug.