Bug 169967 - GFS spec file should not include /usr/lib/* in %files
GFS spec file should not include /usr/lib/* in %files
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Chris Feist
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-05 18:20 EDT by Jos Vos
Modified: 2010-01-11 22:07 EST (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2006-0269
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-27 13:11:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for makefile to install symlinks in place of copies (635 bytes, patch)
2005-10-27 14:43 EDT, Jeff Layton
no flags Details | Diff
specfile patch to prevent .a lib from going into base GFS package (256 bytes, patch)
2005-10-27 14:46 EDT, Jeff Layton
no flags Details | Diff

  None (edit)
Description Jos Vos 2005-10-05 18:20:42 EDT
Description of problem:
Because the GFS spec file includes /usr/lib/* in the %files section, all debug
files (/usr/lib/debug/*) are included in the standard package.  Even worse,
/usr/lib/libgulm* is included and libgulm.so.6 appears to be a normal file and
ldconfig complains about this every time it is called.  Furthermore, libgulm.a
should only be included with the devel package.

Version-Release number of selected component (if applicable):
6.0.2.27-0

Proposed solution:
Do not include /usr/lib/*.  Clean up the libgulm.so* files in the install
section and include /usr/lib/libgulm.so.* in %files.
Comment 1 John Newbigin 2005-10-05 21:58:53 EDT
Should be Version 3
Comment 2 Jos Vos 2005-10-06 05:06:03 EDT
*Release* 3 you mean?  On the ftp sites only the 6.0.2.27-0 src.rpm exists.
Comment 3 John Newbigin 2005-10-06 19:36:39 EDT
It's the Bugzilla terminology used on the web form
Product: Red Hat Cluster Suite
Version: 3

Someone has updated it already (it used to be 4)
Comment 4 Jeff Layton 2005-10-27 14:43:46 EDT
Created attachment 120481 [details]
patch for makefile to install symlinks in place of copies

This patch fixes gulm/lib/Makefile so that it creates symlinks for
libgulm.so.$(RELEASE_MAJOR) and libgulm.so instead of making copies of the
libraries.
Comment 5 Jeff Layton 2005-10-27 14:46:54 EDT
Created attachment 120482 [details]
specfile patch to prevent .a lib from going into base GFS package

Patch for specfile. Only grab the .so libs out of /usr/lib instead of getting
everything there. Prevents rpm from grabbing the .a lib for the base GFS
package.
Comment 6 Chris Feist 2005-11-15 10:48:15 EST
Both issues should be fixed in the 6.0.2.27-8 version and beyond of GFS.

http://porkchop/dist/3.0E-gfs-errata-candidate/GFS/6.0.2.27-8/
Comment 7 John Newbigin 2006-01-30 00:48:43 EST
Why not fix this in 6.0.2.27-0.1?
Comment 10 Red Hat Bugzilla 2006-03-27 13:11:24 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0269.html

Note You need to log in before you can comment on or make changes to this bug.