Bug 170084 - rhn_check backtraces on scheduled config file import
rhn_check backtraces on scheduled config file import
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management (Show other bugs)
unspecified
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Todd Sanders
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-06 23:08 EDT by Joe deBlaquiere
Modified: 2009-08-21 22:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-21 22:24:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joe deBlaquiere 2005-10-06 23:08:29 EDT
[root@localhost jdeblaquiere]# /usr/sbin/rhn_check -vvvv
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or
package list recently updated)', {})
[root@localhost jdeblaquiere]# /usr/sbin/rhn_check -vvvv
D: check_action {'action': "<?xml
version='1.0'?>\n<methodCall>\n<methodName>configfiles.upload</methodName>\n<params>\n<param>\n<value><int>29120100</int></value>\n</param>\n<param>\n<value><array><data>\n<value><string>/etc/sysconfig</string></value>\n</data></array></value>\n</param>\n</params>\n</methodCall>\n",
'version': 2, 'id': 29120100}
D: logininfo: {'X-RHN-Server-Id': 1005966077, 'X-RHN-Auth-Server-Time':
'1128653758.37', 'X-RHN-Auth': 'Wr6jNhF+YLU9zozPCpXe1w==',
'X-RHN-Auth-Channels': [['rhel-i386-as-4', '20051006154547', '1', '1'],
['rhel-i386-as-4-extras', '20051005092902', '0', '1'],
['rhn-tools-rhel-4-as-i386', '20050929103125', '0', '1']], 'X-RHN-Auth-User-Id':
'', 'X-RHN-Auth-Expire-Offset': '3600.0'}
D: handle_action {'action': "<?xml
version='1.0'?>\n<methodCall>\n<methodName>configfiles.upload</methodName>\n<params>\n<param>\n<value><int>29120100</int></value>\n</param>\n<param>\n<value><array><data>\n<value><string>/etc/sysconfig</string></value>\n</data></array></value>\n</param>\n</params>\n</methodCall>\n",
'version': 2, 'id': 29120100}
D: handle_action actionid = 29120100, version = 2
D: do_call configfiles.upload (29120100, ['/etc/sysconfig'])
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 174, in run_action
    (status, message, data) = do_call(method, params)
  File "/usr/sbin/rhn_check", line 91, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/configfiles.py", line 168, in upload
    r = rpc_cli_repository.ClientRepository()
TypeError: __init__() takes exactly 2 arguments (1 given)
D: Sending back response ((6,), 'Fatal error in Python code occured', {})
D: do_call packages.checkNeedUpdate ('rhnsd=1',)
D: local action status:  (0, 'rpm database not modified since last update (or
package list recently updated)', {})
Comment 1 David Lehman 2005-11-30 13:24:28 EST
Same as bug 174613.
Comment 2 Red Hat Bugzilla 2007-05-03 01:36:51 EDT
User wregglej@redhat.com's account has been closed

Note You need to log in before you can comment on or make changes to this bug.