Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 170094 - Segmentation fault while trying to use non English thesaurus in writer
Segmentation fault while trying to use non English thesaurus in writer
Status: CLOSED DUPLICATE of bug 170091
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-07 02:44 EDT by Piotr Skiba
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-07 05:52:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Piotr Skiba 2005-10-07 02:44:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I have LANG=pl_PL.UTF-8

Whenever I start writer, type any word and select Narzedzia->Jezyk->Tezaurus, the program crashes with message: 

/usr/lib/openoffice.org2.0/program/soffice: line 164:  3591 Naruszenie ochrony pamieci   "$sd_prog/$sd_binary" "$@"

There is also a way of reproducing this behavior in English environment:
If I'll run: export LANG=en_US;oowriter, type any word and select Tools->Language->Thesaurus, thesaurus window appears, but when I press language button and choose language other then English, the program crashes with message:

/usr/lib/openoffice.org2.0/program/soffice: line 164:  3802 Segmentation fault      "$sd_prog/$sd_binary" "$@"

If any further details are needed please let me know....

Version-Release number of selected component (if applicable):
openoffice.org-writer-1.9.125-1.1.0.fc4

How reproducible:
Always

Steps to Reproduce:
1. Run oowriter.
2. Type any word.
3. Select Tools->Language->Thesaurus from menu.
4. Choose language other then English.
  

Actual Results:  Program crashes with message:

/usr/lib/openoffice.org2.0/program/soffice: line 164:  3802 Segmentation fault      "$sd_prog/$sd_binary" "$@"

Expected Results:  Non english thesaurus should appear.

Additional info:

FC4 upgraded from FC3 upgraded from FC2 upgraded from FC1 :)

uname -a:
Linux my_own_hostname 2.6.13-1.1526_FC4 #1 Wed Sep 28 19:15:10 EDT 2005 i686 athlon i386 GNU/Linux

I have installed (rpm -qa | grep openoffice):
openoffice.org-langpack-ko_KR-1.9.125-1.1.0.fc4
openoffice.org-langpack-ta_IN-1.9.125-1.1.0.fc4
openoffice.org-langpack-ar-1.9.125-1.1.0.fc4
openoffice.org-langpack-zu_ZA-1.9.125-1.1.0.fc4
openoffice.org-langpack-he_IL-1.9.125-1.1.0.fc4
openoffice.org-langpack-hu_HU-1.9.125-1.1.0.fc4
openoffice.org-langpack-da_DK-1.9.125-1.1.0.fc4
openoffice.org-langpack-zh_CN-1.9.125-1.1.0.fc4
openoffice.org-langpack-de-1.9.125-1.1.0.fc4
openoffice.org-langpack-cs_CZ-1.9.125-1.1.0.fc4
openoffice.org-math-1.9.125-1.1.0.fc4
openoffice.org-langpack-it-1.9.125-1.1.0.fc4
openoffice.org-langpack-fi_FI-1.9.125-1.1.0.fc4
openoffice.org-draw-1.9.125-1.1.0.fc4
openoffice.org-langpack-th_TH-1.9.125-1.1.0.fc4
openoffice.org-langpack-el_GR-1.9.125-1.1.0.fc4
openoffice.org-langpack-hi_IN-1.9.125-1.1.0.fc4
openoffice.org-langpack-bg_BG-1.9.125-1.1.0.fc4
openoffice.org-langpack-lt_LT-1.9.125-1.1.0.fc4
openoffice.org-langpack-cy_GB-1.9.125-1.1.0.fc4
openoffice.org-langpack-nb_NO-1.9.125-1.1.0.fc4
openoffice.org-core-1.9.125-1.1.0.fc4
openoffice.org-langpack-gl_ES-1.9.125-1.1.0.fc4
openoffice.org-langpack-gu_IN-1.9.125-1.1.0.fc4
openoffice.org-langpack-ja_JP-1.9.125-1.1.0.fc4
openoffice.org-langpack-ms_MY-1.9.125-1.1.0.fc4
openoffice.org-langpack-fr-1.9.125-1.1.0.fc4
openoffice.org-langpack-pt_PT-1.9.125-1.1.0.fc4
openoffice.org-langpack-zh_TW-1.9.125-1.1.0.fc4
openoffice.org-langpack-sv-1.9.125-1.1.0.fc4
openoffice.org-langpack-af_ZA-1.9.125-1.1.0.fc4
openoffice.org-langpack-pa_IN-1.9.125-1.1.0.fc4
openoffice.org-langpack-eu_ES-1.9.125-1.1.0.fc4
openoffice.org-langpack-ru-1.9.125-1.1.0.fc4
openoffice.org-langpack-sk_SK-1.9.125-1.1.0.fc4
openoffice.org-langpack-hr_HR-1.9.125-1.1.0.fc4
openoffice.org-calc-1.9.125-1.1.0.fc4
openoffice.org-langpack-pt_BR-1.9.125-1.1.0.fc4
openoffice.org-langpack-et_EE-1.9.125-1.1.0.fc4
openoffice.org-langpack-nn_NO-1.9.125-1.1.0.fc4
openoffice.org-langpack-sl_SI-1.9.125-1.1.0.fc4
openoffice.org-langpack-pl_PL-1.9.125-1.1.0.fc4
openoffice.org-langpack-es-1.9.125-1.1.0.fc4
openoffice.org-langpack-tr_TR-1.9.125-1.1.0.fc4
openoffice.org-langpack-ca_ES-1.9.125-1.1.0.fc4
openoffice.org-writer-1.9.125-1.1.0.fc4
openoffice.org-langpack-nl-1.9.125-1.1.0.fc4
openoffice.org-impress-1.9.125-1.1.0.fc4
Comment 1 Caolan McNamara 2005-10-07 05:52:15 EDT

*** This bug has been marked as a duplicate of 170091 ***

Note You need to log in before you can comment on or make changes to this bug.