Bug 170109 - rebuild from src rpm kernel-2.6.13-1.1526_FC4.src.rpm creates unusable kernel
Summary: rebuild from src rpm kernel-2.6.13-1.1526_FC4.src.rpm creates unusable kernel
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-07 13:00 UTC by Stephen Biggs
Modified: 2015-01-04 22:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-05 07:35:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Biggs 2005-10-07 13:00:26 UTC
Description of problem:
The spec file creates a version name that has a '@' in it.  That is, an example
version of an SMP kernel with username 'user' and machine name 'machinename'
would be 2.6.13-1.1526_FC4.user@machinenamesmp.

The directory is made with the correct name.  uname -a gives
2.6.13-1.1526_FC4.user which cuts off the '@' and everything afterwards.  Upon
boot, no modules are found because the directory name does not match what uname
returns.  Is this a uname bug?

Version-Release number of selected component (if applicable):
kernel 2.6.13-1.1526_FC4
coreutils 5.2.1-48.1

How reproducible:
Always

Steps to Reproduce:
1. Download kernel-2.6.13-1.1526_FC4.src.rpm and do rpm --rebuild of the rpm.
2.
3.
  
Actual results:
uname returns kernel version information that does not match module directory
names (and perhaps other issues), causing at the very least modprobe to fail on
all modules.

Expected results:
uname should return the version with all characters including '@' and afterwards.

Additional info:
A sleazy hack/workaround to fix this is to manually edit the SPEC file and
replace the '@' with '_at_' in the version creation.  This then creates a 
kernel that has loadable drivers.


Note You need to log in before you can comment on or make changes to this bug.