Bug 170111 - iproute breaks networking - cannot talk to rtnetlink
iproute breaks networking - cannot talk to rtnetlink
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: iproute (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Radek Vokal
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-07 09:27 EDT by John Ellson
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: 2.6.14-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-07 22:19:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tested just after installation completed (504 bytes, text/plain)
2005-10-07 21:57 EDT, Jim Cornette
no flags Details

  None (edit)
Description John Ellson 2005-10-07 09:27:49 EDT
Description of problem:
root@ellson:fc-devel# rpm -Uvh iproute-2.6.14-5.i386.rpm
Preparing...                ########################################### [100%]
   1:iproute                ########################################### [100%]
root@ellson:fc-devel# service network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:  Cannot talk to rtnetlink: Invalid argument
                                                           [  OK  ]
Bringing up interface eth0:  Cannot talk to rtnetlink: Invalid argument
Error adding address 135.207.24.103 for eth0.
bind: Cannot assign requested address
Cannot talk to rtnetlink: Invalid argument
Cannot talk to rtnetlink: Invalid argument
                                                           [  OK  ]


Version-Release number of selected component (if applicable):
iproute-2.6.14-5

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:
All networking broken

Expected results:


Additional info:
Problem fixed by reverting to iproute-2.6.14-4

root@ellson:fc-devel.old# rpm -Uvh --oldpackage iproute-2.6.14-4.i386.rpm
Preparing...                ########################################### [100%]
   1:iproute                ########################################### [100%]
root@ellson:fc-devel.old# service network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:                            [  OK  ]
Bringing up interface eth0:                                [  OK  ]
Comment 1 Tom London 2005-10-07 10:07:21 EDT
This works for me.

I get the "Cannot talk to rtnetlink" message, but the interface is brought up.

Do you have dhcdbd installed/enabled?
Comment 2 Sammy 2005-10-07 10:19:01 EDT
I am having the same trouble on my X86_64 system at the latest rawhide level (everything). 
With iproute-2.6.14-5 one is enable to start network. The system hangs at loopback start, 
which seem to hang while running /sbin/ip. Switching iproute to 2.6.13 and earlier (I could 
only find 2.6.11.1) works fine. 
 
This is with the latest kernel in rawhide as well as with 2.6.13-smp.1.1526 kernel from FC4 
updates. 
Comment 3 John Ellson 2005-10-07 10:26:57 EDT
Re comment #1

Enabled?  Don't know.   How can I tell?

The following services listed in NTSYSV are *NOT* selected:

NetworkManager
NetworkManagerDispatcher
dhcp6s
dhcpd
dhcrelay
Comment 4 Tom London 2005-10-07 10:41:17 EDT
I have both NetworkManager services enabled (running on a laptop) and dhcdbd
enabled as well.

The latest dhcdbd package adds itself to the list managed by 'Desktop->System
Settings->Server Settings->Services' (aka system-config-services).  

Not sure if this is the same problem I had before, though.
Comment 5 John Ellson 2005-10-07 11:05:15 EDT
I don't understand the relevance of dhcdbd to this problem?

I have a working desktop system, with static IP address and network configuration,
that breaks just by upgrading iproute from rpm.  Downgrading iproute clears the
problem.   I'm not modifying any other network software.  I'm not even rebooting
the system.

Comment 6 Sammy 2005-10-07 11:10:24 EDT
I have none of those enabled. I just confirmed the ip hang on my i386 system
as well at latest rawhide. I rebuild 2.6.13-3 rpm and this works both on
i386 and 86_64 with older or the latest 2.6.14 based rawhide kernels.
Comment 7 Tom London 2005-10-07 11:12:29 EDT
Sorry, I was just trying to identify differences between your system (that's not
working) and mine (that is working).
Comment 8 John Ellson 2005-10-07 11:25:09 EDT
I didn't mean to criticise.   I just don't understand the connection to dhcdbd
or why one would suspect it as being involved?  

I tried turning it on with "service start dhcbdb" but the problem still exists.
(Why doesn't dhcbdb have an entry in ntsysv ? )

root@ellson:fc-devel# service dhcdbd start
Starting dhcdbd:                                           [  OK  ]
root@ellson:fc-devel# ntsysv
root@ellson:fc-devel# service network restart
Shutting down interface eth0:                              [  OK  ]
Shutting down loopback interface:                          [  OK  ]
Bringing up loopback interface:  Cannot talk to rtnetlink: Invalid argument
                                                           [  OK  ]
Bringing up interface eth0:  Cannot talk to rtnetlink: Invalid argument
Error adding address 135.207.24.103 for eth0.
bind: Cannot assign requested address
Cannot talk to rtnetlink: Invalid argument
Cannot talk to rtnetlink: Invalid argument
                                                           [  OK  ]

Comment 9 Tom London 2005-10-07 14:05:37 EDT
I use dynamic IPs, not static (hence dhcdbd and NM). Sorry, dhcdbd looks like a
red herring.

Checking my /var/log/messages, it appears that after eth0 is configured during
boot (and I get the rtnetlink messages), ntpd fails with DNS errors.  

By the time I login in (run level 5), NetworkManager is running, and all appears
to be fine.
Comment 10 Matt Domsch 2005-10-07 21:41:47 EDT
For the record, the patch noted for iproute works for me on FC4 i386 on the two
systems tested.  service network start succeeds, no problems for me.
Comment 11 Jim Cornette 2005-10-07 21:57:43 EDT
Created attachment 119726 [details]
Tested just after installation completed 

After installation completed and due to notes made to the test list, I saved
the output from a term and cat redirected to a file. Here is "service network
restart" output in the terminal.
Comment 12 Jim Cornette 2005-10-07 21:59:46 EDT
adding to CC
Comment 13 Bill Nottingham 2005-10-07 22:19:37 EDT
It would seem that it was the update to the upstream 050929 snapshot is what
breaks it; updating to the 051007 snapshot fixes it for me.
Comment 14 Bojan Smojver 2005-10-08 06:07:09 EDT
Probably related to this, my box hangs on "bringing up loopback interface" after
the latest updates from Rawhide. Funny enough, and for whatever reason, the box
doesn't want to come up in single user mode either (i.e. I give it an "s" at the
end of the boot line and it boots RL 5 - weird), so I think recovery CDs will be
put in action...
Comment 15 Bojan Smojver 2005-10-08 06:07:44 EDT
Adding myself to CC list.
Comment 16 Bojan Smojver 2005-10-08 07:21:18 EDT
Reverting to 2.6.14-4 fixes the hang here too.
Comment 17 Jim Cornette 2005-10-08 12:17:00 EDT
iproute-2.6.14-6 works and does not exhibit the problem encontered with the
prevous release.

Note You need to log in before you can comment on or make changes to this bug.