Bug 170119 - Kernel panic when booting 2.6.13-1.1526_FC4smp kernel
Kernel panic when booting 2.6.13-1.1526_FC4smp kernel
Status: CLOSED DUPLICATE of bug 169610
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-07 11:00 EDT by Tor Jonsson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-05 02:36:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tor Jonsson 2005-10-07 11:00:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
When i upgraded to kernel 2.6.13-1.1526_FC4smp (downloaded via yum) mkrootdev fails. With kernel 2.6.11-1.1369_FC4smp everything works fine.

The error message is:

Uncompressing Linux... Ok, booting the kernel.
Red Hat nash version 4.2.15 starting
mkrootdev: label / not found

The file systems is:
/dev/sda3 on / type ext3 (rw)
/dev/proc on /proc type proc (rw)
/dev/sys on /sys type sysfs (rw)
/dev/devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda1 on /boot type ext3 (rw)
/dev/shm on /dev/shm type tmpfs (rw)
/dev/hda1 on /home type ext3 (rw)



Version-Release number of selected component (if applicable):
kernel 2.6.13-1.1526_FC4smp

How reproducible:
Always

Steps to Reproduce:
1.Reboot with kernel 2.6.13-1.1526_FC4smp


Additional info:
Comment 1 Tor Jonsson 2005-10-07 11:23:19 EDT
More detailed error message:

root (hd0,0)
Filesystemtype is ext2fs, partitiontype 0x83
kernel /vmlinuz-2.6.13-1.1526_FC4smp ro root=LABEL=/ rhgb quiet
   [Linux-bzImage, setup=0x1e00, size=0e184aa0]
initrd /initrd-2.6.13-1.1526_FC4smp.img
   [Linux-initrd @ 0x37ec0000 size0x12f13c bytes]

Uncompressing Linux... Ok, booting the kernel.
Red Hat nash version 4.2.15 starting
mkrootdev: label / not found
mount: error 2 mounting ext3
ERROR opening /dev/console!!!!: 2
error dup2 ing fd of 0 to 0
error dup2 ing fd of 0 to 1
error dup2 ing fd of 0 to 2
switchroot: mount failed: 22
Kernel panic - not synching: Attempted to kill init!
Comment 2 Chris Elmquist 2005-10-21 13:55:08 EDT
I have this problem on a Dell 2850 machine.  The problem began when the kernel
was updated to any 2.6.13 flavor such as the last TWO FC4 kernel updates.  Prior
to that, with the original FC4 2.6.11 kernel, the problem did not exist on this
machine.  So, I can boot 2.6.11-1.1369_FC4smp with no problem but any FC4 kernel
later than that will cause the panic, claiming unable to find the label "/".

Additionally, I have a Dell 1850 which is almost identical hardware-- with only
the backplane being different.  On the 1850 it is a PCIe backplane and the 2850
is PCIx.  All other components in the two machines are identical.  This 1850
experiences no problem with any kernel including the latest 2.6.13-1.1526 that
was updated in the last day or so.
Comment 3 Chris Elmquist 2005-10-21 16:31:59 EDT
CORRECTION:  I was mistaken about which kernel was on the 1850 machine.  It now
appears that the 1850 was running 2.6.12-1.1447_FC4smp.  When it is upgraded to
2.6.13-1.1526, it fails the same way as the 2850.  So, this is good news/bad
news.  Good news that there is not some bizarre platform difference causing
this.  Bad news that it is a consistant failure in 2.6.13 for these Dell machines.

The 2850 was just installed with FC4 and upgraded today.  So it went from 2.6.11
to 2.6.13 immediately, skipping 2.6.12.  I suspect it would boot 2.6.12 without
trouble just as the 1850 does.  I can do that experiment if anyone needs proof.

How else can I help?

here is an 'lspci' of the 1850:
[root@mig207 ~]# lspci
00:00.0 Host bridge: Intel Corporation E7520 Memory Controller Hub (rev 09)
00:02.0 PCI bridge: Intel Corporation E7525/E7520/E7320 PCI Express Port A (rev 09)
00:04.0 PCI bridge: Intel Corporation E7525/E7520 PCI Express Port B (rev 09)
00:05.0 PCI bridge: Intel Corporation E7520 PCI Express Port B1 (rev 09)
00:06.0 PCI bridge: Intel Corporation E7520 PCI Express Port C (rev 09)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI #3
(rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface
Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller
(rev 02)
01:00.0 PCI bridge: Intel Corporation 80332 [Dobson] I/O processor (rev 06)
01:00.2 PCI bridge: Intel Corporation 80332 [Dobson] I/O processor (rev 06)
02:05.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X
Fusion-MPT Dual Ultra320 SCSI (rev 08)
04:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit
Ethernet PCI Express (rev 11)
05:00.0 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge A (rev 09)
05:00.2 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge B (rev 09)
06:07.0 Ethernet controller: Intel Corporation 82541GI/PI Gigabit Ethernet
Controller (rev 05)
07:08.0 Ethernet controller: Intel Corporation 82541GI/PI Gigabit Ethernet
Controller (rev 05)
08:00.0 InfiniBand: Mellanox Technologies MT25208 InfiniHost III Ex (Tavor
compatibility mode) (rev a0)
09:0d.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon
7000/VE]

and here is an lspci of the 2850:
[root@mig208 ~]# lspci
00:00.0 Host bridge: Intel Corporation E7520 Memory Controller Hub (rev 09)
00:02.0 PCI bridge: Intel Corporation E7525/E7520/E7320 PCI Express Port A (rev 09)
00:04.0 PCI bridge: Intel Corporation E7525/E7520 PCI Express Port B (rev 09)
00:05.0 PCI bridge: Intel Corporation E7520 PCI Express Port B1 (rev 09)
00:06.0 PCI bridge: Intel Corporation E7520 PCI Express Port C (rev 09)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI
Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI #3
(rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI
Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface
Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller
(rev 02)
01:00.0 PCI bridge: Intel Corporation 80332 [Dobson] I/O processor (rev 06)
01:00.2 PCI bridge: Intel Corporation 80332 [Dobson] I/O processor (rev 06)
02:05.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X
Fusion-MPT Dual Ultra320 SCSI (rev 08)
02:05.1 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X
Fusion-MPT Dual Ultra320 SCSI (rev 08)
05:00.0 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge A (rev 09)
05:00.2 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge B (rev 09)
06:07.0 Ethernet controller: Intel Corporation 82541GI/PI Gigabit Ethernet
Controller (rev 05)
07:08.0 Ethernet controller: Intel Corporation 82541GI/PI Gigabit Ethernet
Controller (rev 05)
08:00.0 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge A (rev 09)
08:00.2 PCI bridge: Intel Corporation 6700PXH PCI Express-to-PCI Bridge B (rev 09)
0a:02.0 PCI bridge: Mellanox Technologies MT23108 PCI Bridge (rev a1)
0b:00.0 InfiniBand: Mellanox Technologies MT23108 InfiniHost (rev a1)
0c:0d.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon
7000/VE]

1850 kernel and modules:

root@mig207 ~]# uname -a
Linux mig207.americas.sgi.com 2.6.12-1.1447_FC4smp #1 SMP Fri Aug 26 20:57:13
EDT 2005 i686 i686 i386 GNU/Linux
[root@mig207 ~]# lsmod
Module                  Size  Used by
md5                     8129  1 
ipv6                  266625  16 
parport_pc             31749  0 
lp                     16713  0 
parport                39433  2 parport_pc,lp
autofs4                22981  2 
i2c_dev                13633  0 
i2c_core               25537  1 i2c_dev
nfs                   198537  1 
lockd                  64233  2 nfs
sunrpc                140421  3 nfs,lockd
video                  20037  0 
button                  8129  0 
battery                13508  0 
ac                      8901  0 
uhci_hcd               35537  0 
ehci_hcd               38093  0 
hw_random               9685  0 
shpchp                 97221  0 
ib_mthca              102365  0 
ib_mad                 33761  1 ib_mthca
ib_core                44481  2 ib_mthca,ib_mad
tg3                    98245  0 
e1000                 106029  0 
floppy                 62549  0 
dm_snapshot            21349  0 
dm_zero                 6081  0 
dm_mirror              26013  0 
ext3                  133193  2 
jbd                    61913  1 ext3
dm_mod                 59749  6 dm_snapshot,dm_zero,dm_mirror
mptscsih               39869  0 
mptbase                49505  1 mptscsih
sd_mod                 22977  3 
scsi_mod              136457  2 mptscsih,sd_mod

2850 kernel and modules:

[root@mig208 ~]# uname -a
Linux mig208.americas.sgi.com 2.6.11-1.1369_FC4smp #1 SMP Thu Jun 2 23:08:39 EDT
2005 i686 i686 i386 GNU/Linux
[root@mig208 ~]# lsmod
Module                  Size  Used by
md5                     8001  1 
ipv6                  265857  16 
parport_pc             31621  0 
lp                     16585  0 
parport                39049  2 parport_pc,lp
autofs4                22725  2 
rfcomm                 46041  0 
l2cap                  33857  5 rfcomm
bluetooth              56645  4 rfcomm,l2cap
sunrpc                139781  1 
dm_mod                 59749  0 
video                  19909  0 
button                 10577  0 
battery                13381  0 
ac                      8773  0 
uhci_hcd               35409  0 
ehci_hcd               38093  0 
hw_random               9557  0 
shpchp                 96965  0 
ib_mthca              101725  0 
ib_mad                 33505  1 ib_mthca
ib_core                44225  2 ib_mthca,ib_mad
e1000                 106029  0 
floppy                 62421  0 
sg                     41313  0 
ext3                  133193  3 
jbd                    61785  1 ext3
mptscsih               39869  0 
mptbase                49505  1 mptscsih
sd_mod                 22977  6 
scsi_mod              136457  3 sg,mptscsih,sd_mod


Comment 4 Antony Nguyen 2005-10-21 19:16:46 EDT
Hey guys,

I may have a fix - this is for those of you with LSI SCSI cards upgrading to the
latest 2.6.13 kernel via yum:

http://forums.fedoraforum.org/showthread.php?p=387546

(scroll to the bottom, I'm "Ant")

I'm going to be submitting a bug report soon that describes the situation fully.
 I think mkinitrd has to be updated in order for future
upgrades-from-fresh-installs to work...

Take care,
Tony
Comment 5 Antony Nguyen 2005-10-21 21:18:41 EDT
DJ pointed me to what appears to be a simpler fix:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=FC4_FUSION

--tony
Comment 6 Chris Elmquist 2005-10-21 22:25:12 EDT
I tried this last suggested fix with success!  I was able to boot the Dell 2850
(remotely no less) after making the changes to modprobe.conf.  I'll take care of
the 1850 when I get back to work on Monday.  Thanks guys.  It doesn't look like
too serious of an issue so we'll hope to see an official fix in the next kernel
update.

Regards,

Chris
Network Engineering
SGI
Comment 7 Dave Jones 2005-11-05 02:36:29 EST

*** This bug has been marked as a duplicate of 169610 ***

Note You need to log in before you can comment on or make changes to this bug.