Bug 170155 - epiphany" uses serif fonts until preferences panel is opened
Summary: epiphany" uses serif fonts until preferences panel is opened
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: epiphany   
(Show other bugs)
Version: 12
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords: Reopened, Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-10-07 19:38 UTC by Joachim Frieben
Modified: 2010-08-28 20:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-28 20:10:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
default "index.html" page rendered before preferences panel got opened (83.65 KB, image/png)
2005-10-08 08:52 UTC, Joachim Frieben
no flags Details
Default "index.html" page rendered before preferences panel got opened (83.65 KB, image/png)
2005-10-08 08:53 UTC, Joachim Frieben
no flags Details
Default "index.html" page rendered after preferences panel got opened (88.15 KB, image/png)
2005-10-08 08:54 UTC, Joachim Frieben
no flags Details
Sample screenshot before openening "Detailed Font Settings..." (196.75 KB, image/png)
2006-01-31 11:48 UTC, Joachim Frieben
no flags Details
Sample screenshot after openening "Detailed Font Settings..." (200.18 KB, image/png)
2006-01-31 11:49 UTC, Joachim Frieben
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 330313 None None None Never

Description Joachim Frieben 2005-10-07 19:38:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.11) Gecko/20050914 Epiphany/1.8.2

Description of problem:
After logging in to a GNOME session for the very first time,
"epiphany" uses serif fonts when it should use sans serif ones.
At least, this is what becomes apparent when going to the default
page "index.html". Only after opening the preferences panel, the
fonts suddenly change even without any modification of the font
settings. It looks as if the default font settings are not read
properly unless you force it by opening the preferences panel.


Version-Release number of selected component (if applicable):
epiphany-1.8.2-1

How reproducible:
Always

Steps to Reproduce:
1. Log in to a fresh GNOME session (no dot directories).
2. Launch "epiphany".

  

Actual Results:  The default home page is displayed. The used font is Times serif.

Expected Results:  I guess "epiphany" should have used a sans serif font, because that
is what is being used after the preferences panel has been opened.

Additional info:

This bug has been around since the earliest versions.

Comment 1 Joachim Frieben 2005-10-08 08:52:55 UTC
Created attachment 119730 [details]
default "index.html" page rendered before preferences panel got opened

Comment 2 Joachim Frieben 2005-10-08 08:53:02 UTC
Created attachment 119731 [details]
Default "index.html" page rendered before preferences panel got opened

Comment 3 Joachim Frieben 2005-10-08 08:54:26 UTC
Created attachment 119732 [details]
Default "index.html" page rendered after preferences panel got opened

Comment 4 Joachim Frieben 2006-01-13 09:37:27 UTC
Still not fixed in "epiphany-1.9.4-1". The fonts sizes get also
set to the correct values only after going to the preferences panel.

Comment 5 Joachim Frieben 2006-01-31 11:47:25 UTC
In "epiphany-1.9.6-1", sans serif fonts are used right from the start.
However, most fonts are too small. Only after going to

  "Preferences" -> "Fonts & Style" -> "Detailed Font Settings..."

the size of the concerned fonts jumps instantaneously to the right
values. This is apparently due to the same bug that caused the use of
serif instead of sans serif fonts. See 2 attached screenshots for the
"before/after" effect.

Comment 6 Joachim Frieben 2006-01-31 11:48:28 UTC
Created attachment 123904 [details]
Sample screenshot before openening "Detailed Font Settings..."

Comment 7 Joachim Frieben 2006-01-31 11:49:10 UTC
Created attachment 123905 [details]
Sample screenshot after openening "Detailed Font Settings..."

Comment 8 Joachim Frieben 2006-02-20 20:47:18 UTC
Font size problem still not fixed in "epiphany-1.9.7-1". Only after
opening "Detailed Font Settings...", the font sizes jump to their
right values.

Comment 9 Christopher Aillon 2006-02-20 20:51:54 UTC
Upstream issue.  Filed http://bugzilla.gnome.org/show_bug.cgi?id=330313

Comment 10 Joachim Frieben 2009-10-18 10:42:17 UTC
This bug has -not- been fixed upstream. It is still present for epiphany-2.26.3-4.fc11.x86_64.

Comment 11 Bug Zapper 2009-11-16 07:50:04 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping


Note You need to log in before you can comment on or make changes to this bug.