Bug 170178 - Compilation failed: lvm2-2.01.14-2.0.RHEL4.src.rpm
Compilation failed: lvm2-2.01.14-2.0.RHEL4.src.rpm
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: lvm2 (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
: 180750 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-08 07:21 EDT by Vesselin Kolev
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 13:31:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vesselin Kolev 2005-10-08 07:21:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
Compilation fails with output:

/lib/libdevmapper.a(libdm-common.o)(.text+0x55a): In function `set_selinux_context':
: multiple definition of `set_selinux_context'
../lib/liblvm.a(selinux.o)(.text+0x0):misc/selinux.c:22: first defined here
/usr/bin/ld: Warning: size of symbol `set_selinux_context' changed from 325 in ../lib/liblvm.a(selinux.o) to 327 in /lib/libdevmapper.a(libdm-common.o)
../lib/liblvm.a(sharedlib.o)(.text+0x10e): In function `load_shared_library':
misc/sharedlib.c:43: warning: Using 'dlopen' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/gcc/i386-redhat-linux/3.4.4/../../../libreadline.a(complete.o)(.text+0x1b90): In function `rl_username_completion_function':
: warning: Using 'getpwent' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/gcc/i386-redhat-linux/3.4.4/../../../libreadline.a(tilde.o)(.text+0x1b1): In function `tilde_expand_word':
: warning: Using 'getpwnam' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/gcc/i386-redhat-linux/3.4.4/../../../libreadline.a(shell.o)(.text+0xf2): In function `sh_get_home_dir':
: warning: Using 'getpwuid' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/gcc/i386-redhat-linux/3.4.4/../../../libreadline.a(complete.o)(.text+0x1b8b): In function `rl_username_completion_function':
: warning: Using 'setpwent' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
/usr/lib/gcc/i386-redhat-linux/3.4.4/../../../libreadline.a(complete.o)(.text+0x1c28): In function `rl_username_completion_function':
: warning: Using 'endpwent' in statically linked applications requires at runtime the shared libraries from the glibc version used for linking
collect2: ld returned 1 exit status
make[1]: *** [lvm.static] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/LVM2.2.01.14/tools'
make: *** [tools] Error 2


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpmbuild -ba lvm2.spec
  

Additional info:

Required packages are available:

device-mapper-1.01.04-1.0.RHEL4
libselinux-devel-1.19.1-7
libtermcap-devel-2.0.8-39
ncurses-devel-5.4-13
readline-devel-4.3-13

kernel-2.6.9-22.EL


Other packages:

glibc-2.3.4-2.13
glibc-headers-2.3.4-2.13
gcc-3.4.4-2
Comment 1 Jos Vos 2005-10-23 09:43:40 EDT
It looks like this is due to an incompatibility with the device-mapper RPM of
RHEL4 U2.  When you downgrade device-mapper to 1.01.01-1.RHEL4, it works.

Note that the dmraid in RHEL4 U2 package has a similar same problem.
Comment 2 Alasdair Kergon 2005-10-25 13:15:47 EDT
I recall seeing that error message before, but can't remember the details at the moment.
Comment 3 Alasdair Kergon 2005-10-25 13:31:17 EDT
Since libdevmapper interface is undergoing changes for U3 anyway, I've removed set_selinux_context from 
lvm2 and changed lvm2 to use the device-mapper version, so any problem should disappear in U3.
Comment 4 Alasdair Kergon 2006-02-10 15:50:53 EST
*** Bug 180750 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.