Bug 170210 - Grub will not install bootloader with grub-install
Grub will not install bootloader with grub-install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-08 23:03 EDT by Reuben Farrelly
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-31 15:45:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2005-10-08 23:03:25 EDT
Something appears to have broken with grub, such that the current version in
rawhide is no longer able to install a boot loader using grub-install.

grub-1

With grub-0.95-15 this is what happens:

[root@typhoon ~]# grub-install /dev/sdc
No suitable drive was found in the generated device map,
reverting to backed up copy.
mv: cannot stat `/boot/grub/device.map.backup': No such file or directory
[root@typhoon ~]#


With grub-0.95-13 installation looks like this:

[root@typhoon reuben]# grub-install /dev/sdc
Installation finished. No error reported.
This is the contents of the device map /boot/grub/device.map.
Check if this is correct or not. If any of the lines is incorrect,
fix it and re-run the script `grub-install'.

(fd0)   /dev/fd0
(hd0)   /dev/sda
(hd1)   /dev/sdc
[root@typhoon reuben]#
Comment 1 Jeremy Katz 2006-01-31 15:33:09 EST
Is this better in FC5 test2?
Comment 2 Reuben Farrelly 2006-01-31 15:45:34 EST
Yes.  It works fine now, (albeit slowly).

I'll mark this one as fixed.

Note You need to log in before you can comment on or make changes to this bug.