Bug 170214 - cdrecord OPC failed
cdrecord OPC failed
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
: 170215 170216 170217 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-09 02:17 EDT by Russell Strong
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-24 17:40:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mahowald 2005-10-09 14:03:35 EDT
*** Bug 170217 has been marked as a duplicate of this bug. ***
Comment 1 John Mahowald 2005-10-09 14:04:41 EDT
*** Bug 170216 has been marked as a duplicate of this bug. ***
Comment 2 John Mahowald 2005-10-09 14:06:30 EDT
*** Bug 170215 has been marked as a duplicate of this bug. ***
Comment 3 John Mahowald 2005-10-09 14:10:51 EDT
Thank you for taking the time to report this bug. This bug report isn't very
useful because it doesn't describe the bug well. If you have time and can
still reproduce the bug, please read 
http://fedoraproject.org/wiki/ReportingBugs and add a more useful 
description to this bug.
Thank you.
Comment 4 John Mahowald 2005-10-11 12:23:57 EDT
From: Russell Strong
To: jpmahowald@gmail.com


I've tried numerous times to raise this bug ( with a lot more
information included ) however I kept getting an internal server error
coming back.  I wasn't aware that any thing had been recorded, hence all
the duplicates.

I've just tried to add more information however, this time the server
just doesn't respond. So I'm giving it to you via email.

The problem results in the following message when trying to record the
FC4 disk 1 iso to a CDR

scsidev: '/dev/cdrom'
devname: '/dev/cdrom'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
Using libscg version 'schily-0.8'.
cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c
1.83 04/05/20 Copyright 1997 J. Schilling').
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   :
Vendor_info    : 'MATSHITA'
Identifikation : 'DVD-RAM UJ-830S '
Revision       : '1.00'
Device seems to be: Generic mmc2 DVD-R/DVD-RW.
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE
Supported modes: TAO PACKET SAO
cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
cdrecord: WARNING: This causes a high risk for buffer underruns.
Speed set to 1411 KB/s
Starting to write CD/DVD at speed   8.0 in real TAO mode for single
session.
Last chance to quit, starting real write    0 seconds. Operation starts.
trackno=0
cdrecord: Success. send opc: scsi sendcmd: no error
CDB:  54 01 00 00 00 00 00 00 00 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 03 00 00 00 00 0A 00 00 15 11 73 03 00 00
Sense Key: 0x3 Medium Error, Segment 0
Sense Code: 0x73 Qual 0x03 (power calibration area error) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 8.856s timeout 60s
cdrecord: OPC failed.


I am using magmedia CDR-80,  I have tried 3 of these, all the same.
I have since tried a different CDR manufacturer, Sony, and it worked
fine.
Comment 5 Eric Wheeler 2005-11-13 00:25:48 EST
Devices
-----------------------
TEAC DVD+RW DV-W58E D.0C (/dev/hdc, ) at /media/cdrecorder [CD-R; CD-RW; CD-ROM;
DVD-ROM; DVD+R; DVD+RW] [DVD-ROM; DVD+RW; DVD+R; CD-ROM; CD-R; CD-RW] [SAO; TAO;
RAW; RAW/R96R]

System
-----------------------
K3b Version: 0.11.23
KDE Version: 3.4.2-0.fc4.1 Red Hat
QT Version:  3.3.4
Kernel:      2.6.13-1.1532_FC4

cdrecord
-----------------------
/usr/bin/cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
/usr/bin/cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c 1.83 04/05/20
Copyright 1997 J. Schilling').
SCSI buffer size: 64512
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
Using libscg version 'schily-0.8'.
Driveropts: 'burnfree'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   : 
Vendor_info    : 'TEAC    '
Identifikation : 'DVD+RW DV-W58E  '
Revision       : 'D.0C'
Device seems to be: Generic mmc2 DVD-ROM.
Current: 0x0009
Profile: 0x001B 
Profile: 0x001A 
Profile: 0x0010 
Profile: 0x000A 
Profile: 0x0009 (current)
Profile: 0x0008 
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE 
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R96R
Drive buf size : 1613472 = 1575 KB
FIFO size      : 4194304 = 4096 KB
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
Track 01: data   390 MB        
Total size:      447 MB (44:22.61) = 199696 sectors
Lout start:      448 MB (44:24/46) = 199696 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 5
  Is not unrestricted
  Is not erasable
  Disk sub type: Medium Type A, high Beta category (A+) (3)
  ATIP start of lead in:  -11634 (97:26/66)
  ATIP start of lead out: 359848 (79:59/73)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 3
Manufacturer: CMC Magnetics Corporation
Blocks total: 359848 Blocks current: 359848 Blocks remaining: 160152
Speed set to 5645 KB/s
Starting to write CD/DVD at speed  32.0 in real SAO mode for single session.
Last chance to quit, starting real write in 2 seconds.
   1 seconds.
   0 seconds.
 Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
trackno=0
BURN-Free is OFF.
Turning BURN-Free on
Performing OPC...
Sending CUE sheet...
/usr/bin/cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Writing pregap for track 1 at -150
Starting new track at sector: 0
Track 01:    0 of  390 MB written.
/usr/bin/cdrecord: Success. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 00 00 9B 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 04 00 00 00 00 0A 00 00 00 00 08 03 00 00
Sense Key: 0x4 Hardware Error, Segment 0
Sense Code: 0x08 Qual 0x03 (logical unit communication crc error (ultra-dma/32))
Fru 0x0
Sense flags: Blk 0 (not valid) 
resid: 63488
cmd finished after 0.025s timeout 200s
/usr/bin/cdrecord: A write error occured.
/usr/bin/cdrecord: Please properly read the error message above.
write track data: error after 317440 bytes
Writing  time:   21.740s
Average write speed 180.1x.
Fixating...
Fixating time:    3.055s
/usr/bin/cdrecord: fifo had 69 puts and 6 gets.
/usr/bin/cdrecord: fifo was 0 times empty and 5 times full, min fill was 98%.

cdrecord comand:
-----------------------
/usr/bin/cdrecord -v gracetime=2 dev=/dev/hdc speed=32 -dao driveropts=burnfree
-eject -data /home/eric/Desktop/VL-5.1-std.iso 

instance #2 output:

Devices
-----------------------
LG CD-ROM CRD-8482B 1.05 (/dev/hdd, ) at /media/cdrom [CD-ROM] [Error] [None]
TEAC DVD+RW DV-W58E D.0C (/dev/hdc, ) at /media/cdrecorder [CD-R; CD-RW; CD-ROM;
DVD-ROM; DVD+R; DVD+RW] [DVD-ROM; DVD+RW; DVD+R; CD-ROM; CD-R; CD-RW] [SAO; TAO;
RAW; RAW/R96R]

System
-----------------------
K3b Version: 0.11.23
KDE Version: 3.4.2-0.fc4.1 Red Hat
QT Version:  3.3.4
Kernel:      2.6.13-1.1532_FC4

cdrecord
-----------------------
/usr/bin/cdrecord: Cannot allocate memory. WARNING: Cannot do mlockall(2).
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Linux sg driver version: 3.5.27
/usr/bin/cdrecord: Warning: using inofficial libscg transport code version
(schily - Red Hat-scsi-linux-sg.c-1.83-RH '@(#)scsi-linux-sg.c 1.83 04/05/20
Copyright 1997 J. Schilling').
SCSI buffer size: 64512
Cdrecord-Clone 2.01-dvd (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
Note: This version is an unofficial (modified) version with DVD support
Note: and therefore may have bugs that are not present in the original.
Note: Please send bug reports or support requests to
http://bugzilla.redhat.com/bugzilla
Note: The author of cdrecord should not be bothered with problems in this version.
TOC Type: 1 = CD-ROM
Using libscg version 'schily-0.8'.
Driveropts: 'burnfree'
atapi: 1
Device type    : Removable CD-ROM
Version        : 0
Response Format: 2
Capabilities   : 
Vendor_info    : 'TEAC    '
Identifikation : 'DVD+RW DV-W58E  '
Revision       : 'D.0C'
Device seems to be: Generic mmc2 DVD-ROM.
Current: 0x0009
Profile: 0x001B 
Profile: 0x001A 
Profile: 0x0010 
Profile: 0x000A 
Profile: 0x0009 (current)
Profile: 0x0008 
Using generic SCSI-3/mmc   CD-R/CD-RW driver (mmc_cdr).
Driver flags   : MMC-3 SWABAUDIO BURNFREE 
Supported modes: TAO PACKET SAO SAO/R96P SAO/R96R RAW/R96R
Drive buf size : 1613472 = 1575 KB
FIFO size      : 4194304 = 4096 KB
/usr/bin/cdrecord: Operation not permitted. WARNING: Cannot set RR-scheduler
/usr/bin/cdrecord: Permission denied. WARNING: Cannot set priority using
setpriority().
/usr/bin/cdrecord: WARNING: This causes a high risk for buffer underruns.
Track 01: data   390 MB        
Total size:      447 MB (44:22.61) = 199696 sectors
Lout start:      448 MB (44:24/46) = 199696 sectors
Current Secsize: 2048
ATIP info from disk:
  Indicated writing power: 5
  Is not unrestricted
  Is not erasable
  Disk sub type: Medium Type A, high Beta category (A+) (3)
  ATIP start of lead in:  -11634 (97:26/66)
  ATIP start of lead out: 359848 (79:59/73)
Disk type:    Short strategy type (Phthalocyanine or similar)
Manuf. index: 3
Manufacturer: CMC Magnetics Corporation
Blocks total: 359848 Blocks current: 359848 Blocks remaining: 160152
Speed set to 5645 KB/s
Starting to write CD/DVD at speed  32.0 in real SAO mode for single session.
Last chance to quit, starting real write in 2 seconds.
   1 seconds.
   0 seconds.
 Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
trackno=0
BURN-Free is OFF.
Turning BURN-Free on
Performing OPC...
Sending CUE sheet...
/usr/bin/cdrecord: WARNING: Drive returns wrong startsec (0) using -150
Writing pregap for track 1 at -150
Starting new track at sector: 0
Track 01:    0 of  390 MB written.
/usr/bin/cdrecord: Success. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 00 00 9B 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 04 00 00 00 00 0A 00 00 00 00 08 03 00 00
Sense Key: 0x4 Hardware Error, Segment 0
Sense Code: 0x08 Qual 0x03 (logical unit communication crc error (ultra-dma/32))
Fru 0x0
Sense flags: Blk 0 (not valid) 
resid: 63488
cmd finished after 0.052s timeout 200s
/usr/bin/cdrecord: A write error occured.
/usr/bin/cdrecord: Please properly read the error message above.
write track data: error after 317440 bytes
Writing  time:   22.624s
Average write speed 172.0x.
Fixating...
Fixating time:    2.162s
/usr/bin/cdrecord: fifo had 69 puts and 6 gets.
/usr/bin/cdrecord: fifo was 0 times empty and 5 times full, min fill was 98%.

cdrecord comand:
-----------------------
/usr/bin/cdrecord -v gracetime=2 dev=/dev/hdc speed=32 -dao driveropts=burnfree
-eject -data /home/eric/Desktop/VL-5.1-std.iso 

Comment 6 Harald Hoyer 2005-11-14 02:14:41 EST
Eric, this sounds like a HW/cable problem.

Sense Key: 0x4 Hardware Error, Segment 0
Sense Code: 0x08 Qual 0x03 (logical unit communication crc error (ultra-dma/32))
Comment 7 Russell Strong 2006-02-24 17:40:15 EST
I've had no further trouble with any other discs.  If everyone else is happy to
close this, please close as a bad bunch of discs for me.

Note You need to log in before you can comment on or make changes to this bug.