Bug 170237 - evince don't map Helvetica fonts proper on printing
evince don't map Helvetica fonts proper on printing
Product: Fedora
Classification: Fedora
Component: poppler (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Depends On:
  Show dependency treegraph
Reported: 2005-10-09 17:47 EDT by Peter Bieringer
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: poppler-0.4.3-1.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-12-21 09:55:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
PDF file with Helvetica fonts not included (25.18 KB, application/pdf)
2005-10-09 17:48 EDT, Peter Bieringer
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 318920 None None None Never

  None (edit)
Description Peter Bieringer 2005-10-09 17:47:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
Evince has problems on printing a PDF proper, if Helvetica fonts are not included in PDF

Version-Release number of selected component (if applicable):
evince-0.4.0-1.2  poppler-0.4.1-1.1

How reproducible:

Steps to Reproduce:
1. load attached PDF in evince, xpdf, gsview
2. compare screen shots -> loos ok
3. compare printouts -> evince doesn't map Helvetica font definitions proper

Actual Results:  Not proper printout

Expected Results:  Proper printout

Additional info:
Comment 1 Peter Bieringer 2005-10-09 17:48:18 EDT
Created attachment 119750 [details]
PDF file with Helvetica fonts not included
Comment 2 Peter Bieringer 2005-10-09 18:19:10 EDT
I've upgraded to poppler from testing (by rebuilding also cairo), it doesn't
help. I can't upgrade to evince from testing, because it claims on rebuild about:

checking for GDU_MODULE_VERSION_CHECK... Requested 'gnome-doc-utils >= 0.3.2'
but version of gnome-doc-utils is 0.2.0
configure: error: Package requirements (gnome-doc-utils >= 0.3.2) were not met.
Comment 3 Tom Cross 2005-12-05 14:53:49 EST
I'm having the exact same problem with evince and the "Times" font.

View on screen using evince:  Looks fine.
print from evince:  fonts are screwed up.

lpr filename.pdf:  looks perfectly fine.
Comment 4 Tom Cross 2005-12-05 15:11:18 EST
I believe this is the same bug:

Comment 5 Alex Lancaster 2005-12-21 09:18:44 EST
Latest FC4 update to poppler (poppler-0.4.3-1.3) fixes this for me.  If this can
be verified by original reporter, bug component should be changed to "poppler"
and should then be closed as ERRATA.

Added link to the upstream GNOME bug.
Comment 6 Peter Bieringer 2005-12-21 09:33:31 EST
Can also confirm that it is fixed now.
Comment 7 Alex Lancaster 2005-12-21 09:41:08 EST
(In reply to comment #6)
> Can also confirm that it is fixed now.

Since you opened the bug, you should be able to close it.  Probably resolve it
as CURRENTRELEASE and use poppler-0.4.3-1.3 in the release version field.

Note You need to log in before you can comment on or make changes to this bug.