Bug 17024 - headersinsource in spec doesn't work.
headersinsource in spec doesn't work.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-28 01:07 EDT by Red Hat Bugzilla
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-13 17:03:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A headersinsource patch for kernel spec (580 bytes, patch)
2000-08-28 01:08 EDT, Red Hat Bugzilla
no flags Details | Diff
A rpm patch for kernel spec file. (3.65 KB, patch)
2000-08-28 12:15 EDT, Red Hat Bugzilla
no flags Details | Diff

  None (edit)
Description Red Hat Bugzilla 2000-08-28 01:07:12 EDT
The headersinsource macro in spec doesn't work. The enclosed patch
works for me.
Comment 1 Red Hat Bugzilla 2000-08-28 01:08:06 EDT
Created attachment 3058 [details]
A headersinsource patch for kernel spec
Comment 2 Red Hat Bugzilla 2000-08-28 12:06:23 EDT
What version of rpm are you using?
Comment 3 Red Hat Bugzilla 2000-08-28 12:14:18 EDT
I am using rpm 3.0.4-0.48 on RedHat 6.2 and rpm 4.0-0.71 on RedHat 7.0 beta
RC2 with a patch. I will attatch my rpm patch.
Comment 4 Red Hat Bugzilla 2000-08-28 12:15:09 EDT
Created attachment 3078 [details]
A rpm patch for kernel spec file.
Comment 5 Red Hat Bugzilla 2000-08-28 12:16:43 EDT
The rpm patch is to deal with the false branch like

%if ! %{headersinsource}
%files headers
%%endif

Note You need to log in before you can comment on or make changes to this bug.