Bug 170304 - Cannot run Preference "Removable Storage." Receive and error message stating Volume Management not Supported.
Cannot run Preference "Removable Storage." Receive and error message stating...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: selinux-policy-targeted (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks: 168429
  Show dependency treegraph
 
Reported: 2005-10-10 13:04 EDT by Tony McDonough
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0049
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 13:12:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony McDonough 2005-10-10 13:04:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
When running the Preference application "Removable Storage" I receive an error stating: 

Volume Management not Supported The hald service is required but not currently running.  Enable the service and rerun the applet....  

I've verified that the hald and dbus-daemon-1 is running.  When I run lshal I have the following error:  

libhal.c 644 : Error connecting to system bus: An SELinux policy prevents this sender from sending this message to this recipient (rejected message had interface "org.freedesktop.DBus" member "Hello" error name "(unset)" destination "org.freedesktop.DBus") error: hal_initialize failed

Version-Release number of selected component (if applicable):
gnome-volume-manager-1.1.0-5

How reproducible:
Always

Steps to Reproduce:
1. In GNOME, go to Preference-->Removable Storage
2.
3.
  

Additional info:
Comment 1 Michael Stevenson 2005-10-19 18:31:22 EDT
To be noted as well is thatwhen media is inserted gnome will not mount it by
itself.  Although this is the defaul action of gnome on a fresh install in U1.

This is reloaded not just to upgrading to U2 but any fresh install on multiple
machines of U2.

The errors Tony are accurate as mine would be.
Comment 2 John (J5) Palmieri 2005-10-19 18:34:06 EDT
Looks like a misconfigured SELinux policy.  Moving to selinux.
Comment 3 Daniel Walsh 2005-10-20 09:46:27 EDT
Are you seeing any avc messages? 
Comment 4 Chris Runge 2005-10-25 16:48:59 EDT
I'm also seeing this error. AVC messages follow:

Oct 25 16:50:40 crunge-laptop dbus: Can't send to audit system: USER_AVC
pid=3078 uid=81 loginuid=-1 message=avc:  denied  { send_msg } for 
scontext=user_u:system_r:unconfined_t tcontext=user_u:system_r:initrc_t tclass=dbus
Oct 25 16:50:45 crunge-laptop dbus: Can't send to audit system: USER_AVC
pid=3078 uid=81 loginuid=-1 message=avc:  denied  { send_msg } for 
scontext=user_u:system_r:unconfined_t tcontext=user_u:system_r:initrc_t tclass=dbus
Oct 25 16:50:50 crunge-laptop dbus: Can't send to audit system: USER_AVC
pid=3078 uid=81 loginuid=-1 message=avc:  denied  { send_msg } for 
scontext=root:system_r:unconfined_t tcontext=user_u:system_r:initrc_t tclass=dbus
Oct 25 16:50:50 crunge-laptop dbus: Can't send to audit system: USER_AVC
pid=3078 uid=81 loginuid=-1 message=avc:  denied  { send_msg } for 
scontext=user_u:system_r:unconfined_t tcontext=user_u:system_r:initrc_t tclass=dbus
Oct 25 16:51:10 crunge-laptop last message repeated 4 times
Oct 25 16:51:13 crunge-laptop dbus: Can't send to audit system: USER_AVC
pid=3078 uid=81 loginuid=-1 message=avc:  denied  { send_msg } for 
scontext=root:system_r:unconfined_t tcontext=user_u:system_r:initrc_t tclass=dbus
Comment 5 Daniel Walsh 2005-10-25 16:56:25 EDT
Please try the policy on 

ftp://people.redhat.com/dwalsh/RHEL4/u3/selinux-policy*
Comment 6 Chris Runge 2005-10-25 17:14:15 EDT
problem appears to be solved with updated targeted policy from
ftp://people.redhat.com/dwalsh/SELinux/RHEL4/u3/
Comment 7 Tony McDonough 2005-10-25 18:15:09 EDT
Updated targetd policy fixed the problem.  Thanks for all the help.
Comment 8 Daniel Walsh 2005-11-21 14:24:04 EST
Fixed in selinux-policy-targeted-1.17.30-2.119
Comment 11 Red Hat Bugzilla 2006-03-07 13:12:27 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0049.html

Note You need to log in before you can comment on or make changes to this bug.