Bug 170324 - Yum exists with Error: Missing Dependency: libwpd-1.so.7 is needed by package abiword
Yum exists with Error: Missing Dependency: libwpd-1.so.7 is needed by package...
Status: CLOSED DUPLICATE of bug 170117
Product: Fedora
Classification: Fedora
Component: libwpd (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-10 14:33 EDT by Antony Harris
Modified: 2014-01-21 17:52 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-11 16:23:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antony Harris 2005-10-10 14:33:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc3 Firefox/1.0.7

Description of problem:
Running "yum update", yum exits with:

Error: Missing Dependency: libwpd-1.so.7 is needed by package abiword

However, libwpd-1.so.7 is on the machine.

"yum provides libwpd-1.so.7" gives:

libwpd.i386                              0.7.2-1                base
Matched from:
/usr/lib/libwpd-1.so.7.0.2
/usr/lib/libwpd-1.so.7
libwpd-1.so.7


libwpd.i386                              0.7.2-1                installed
Matched from:
/usr/lib/libwpd-1.so.7
/usr/lib/libwpd-1.so.7.0.2
libwpd-1.so.7


Also, "yum --exclude=abiword update" exits with:
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package libwpd.i386 0:0.8.2-1.fc3 set to be updated
---> Package libwpd-devel.i386 0:0.8.2-1.fc3 set to be updated
---> Package nut-client.i386 0:2.0.2-0.fc3.2 set to be updated
---> Package wget.i386 0:1.10.1-3.fc3 set to be updated
---> Package w3c-libwww-apps.i386 0:5.4.0-10.0.FC3.1 set to be updated
---> Package libwpd-tools.i386 0:0.8.2-1.fc3 set to be updated
---> Package nut.i386 0:2.0.2-0.fc3.2 set to be updated
---> Package ipxutils.i386 0:2.2.4-5.FC3 set to be updated
---> Package xpdf.i386 1:3.01-0.FC3.2 set to be updated
---> Package w3c-libwww-devel.i386 0:5.4.0-10.0.FC3.1 set to be updated
---> Package w3c-libwww.i386 0:5.4.0-10.0.FC3.1 set to be updated
---> Package nut-cgi.i386 0:2.0.2-0.fc3.2 set to be updated
---> Package mc.i386 1:4.6.1-3.FC3 set to be updated
---> Package ncpfs.i386 0:2.2.4-5.FC3 set to be updated
---> Package udev.i386 0:039-10.FC3.8 set to be updated
---> Package xloadimage.i386 0:4.1-35.FC3 set to be updated
--> Running transaction check
--> Processing Dependency: libwpd-1.so.7 for package: abiword
--> Finished Dependency Resolution
Error: Missing Dependency: libwpd-1.so.7 is needed by package abiword

Notice that abiword is not listed in the packages, but is listed in the "Processing Dependency"!



Version-Release number of selected component (if applicable):
yum-2.2.2-0.fc3 kernel-2.6.12-1.1378_FC3

How reproducible:
Always

Steps to Reproduce:
1. yum update
2.
3.
  

Actual Results:  Nothing get updated.

Expected Results:  The system should have been updated.

Additional info:
Comment 1 Jonathan Wakely 2005-10-10 15:55:54 EDT
I'm seeing this on FC3 x86-64 too.

The problem seems to be that the abiword update is built against the older
libwpd, so updating libwpd breaks the dependency for abiword.

I was able to update all packages except libwpd by listing them explicitly, so
"yum --exclude=libwpd update" should work.

After that, I just get:

# yum update
Setting up Update Process
Setting up Repos
updates-released          100% |=========================|  951 B    00:00
livna-stable              100% |=========================|  951 B    00:00
extras                    100% |=========================|  951 B    00:00
base                      100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
updates-re: ################################################## 1108/1108
livna-stab: ################################################## 266/266
extras    : ################################################## 1793/1793
base      : ################################################## 2852/2852
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package libwpd.x86_64 0:0.8.2-1.fc3 set to be updated
--> Running transaction check
--> Processing Dependency: libwpd-1.so.7()(64bit) for package: abiword
--> Finished Dependency Resolution
Error: Missing Dependency: libwpd-1.so.7()(64bit) is needed by package abiword

So do we need another update for abiword, built against libwpd-0.8 ?
Comment 2 Seth Vidal 2005-10-10 23:31:49 EDT
yes, we do
refiling this against libwpd
Comment 3 Caolan McNamara 2005-10-11 16:23:30 EDT

*** This bug has been marked as a duplicate of 170117 ***

Note You need to log in before you can comment on or make changes to this bug.