Bug 170331 - [PATCH] loader can't parse kickstart correctly when %pre, %post, or %packages have options/args
[PATCH] loader can't parse kickstart correctly when %pre, %post, or %packages...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks: 168429
  Show dependency treegraph
 
Reported: 2005-10-10 15:14 EDT by Jay Turner
Modified: 2015-01-07 19:10 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2006-0126
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-07 16:29:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Brandon Zehm 2005-10-12 13:32:37 EDT
Where's the patch?  My %post isn't working and I'm wondering if this bug is
related to what I'm seeing.
Comment 3 Johnray Fuller 2005-11-22 15:39:35 EST
This is the bug:

The part of loader that parses the kickstart for commands will continue parsing
throughout the %pre/%post/%package sections until one of them doesn't have any
options. This is because in ksReadCommands it strips leading and trailing
whitespace but then checks for the *exact* strings, not just initial substrings.

1. Put a python script as a %pre right after the commands section of ks.cfg 
2. make sure you assign to a variable called 'url' in the python script

Actual results:
You get a hung loader

It sounds like you are seeing a different problem.

J
Comment 7 Red Hat Bugzilla 2006-03-07 16:29:53 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0126.html

Note You need to log in before you can comment on or make changes to this bug.