Bug 170336 - postinstall scriptlet error
postinstall scriptlet error
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: R-mAr (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: José Matos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-10 15:41 EDT by Alex Lancaster
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: R-mAr-1.1-3.fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-11 18:51:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2005-10-10 15:41:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050923 Galeon/1.3.21

Description of problem:
When install R-mAr, the %postinstall scriptlet reports an error:

sudo yum install R-mAr

[...]

Running Transaction
  Installing: kdelibs                      ####################### [ 1/13]
  Installing: SDL_ttf                      ####################### [ 2/13]
  Installing: SDL_gfx                      ####################### [ 3/13]
  Installing: physfs                       ####################### [ 4/13]
  Installing: tk-devel                     ####################### [ 5/13]
  Installing: R-devel                      ####################### [ 6/13]
  Installing: R-mAr                        ####################### [ 7/13]
Unknown option: htmllists
Usage: R CMD build-help.pl [options] [pkg] [lib]

Install all help files for package pkg to library lib

Options:
  -h, --help            print short help message and exit
  -v, --version         print version info and exit
  -d, --debug           print debugging information
  -os, --OS             OS to assume: unix (default) or windows
  --rhome               R home directory, defaults to environment R_HOME
  --html                build HTML files    (default is all)
  --txt                 build text files    (default is all)
  --latex               build LaTeX files   (default is all)
  --example             build example files (default is all)
  --dosnames            use 8.3 filenames
  --index               build index file only


Email bug reports to <r-bugs@r-project.org>.
  Installing: python-simpletal             ####################### [ 8/13]


Version-Release number of selected component (if applicable):
R-mAr-1.1-2.fc4

How reproducible:
Didn't try

Steps to Reproduce:
1. Attempt to install R-mAr via yum:  yum install R-mAr

  

Actual Results:  Extra output produced:

Unknown option: htmllists
Usage: R CMD build-help.pl [options] [pkg] [lib]

Install all help files for package pkg to library lib

Options:
  -h, --help            print short help message and exit
  -v, --version         print version info and exit
  -d, --debug           print debugging information
  -os, --OS             OS to assume: unix (default) or windows
  --rhome               R home directory, defaults to environment R_HOME
  --html                build HTML files    (default is all)
  --txt                 build text files    (default is all)
  --latex               build LaTeX files   (default is all)
  --example             build example files (default is all)
  --dosnames            use 8.3 filenames
  --index               build index file only


Email bug reports to <r-bugs@r-project.org>.

Expected Results:  No output for the yum installation line should have been produced.

Additional info:

It appears that there is a problem with the --htmllists optin, it is apparently an unknown in the version of Perl in Fedora Core 4.

rpm -q --scripts R-mAr
postinstall scriptlet (using /bin/sh):
/usr/bin/R CMD perl /usr/lib/R/share/perl/build-help.pl --htmllists
cat /usr/lib/R/library/*/CONTENTS > /usr/lib/R/doc/html/search/index.txt
postuninstall scriptlet (using /bin/sh):
/usr/bin/R CMD perl /usr/lib/R/share/perl/build-help.pl --htmllists
cat /usr/lib/R/library/*/CONTENTS > /usr/lib/R/doc/html/search/index.txt
Comment 1 José Matos 2005-10-11 07:41:04 EDT
The problem is not perl but /usr/lib/R/share/perl/build-help.pl 
 
This helper script no longer has the --htmllists option. I have asked 
in the r-devel mailing list what is the best advice to proceed from 
here. 
Comment 2 José Matos 2005-10-11 13:33:00 EDT
I have removed the offending lines as they are no longer 
necessary in the new R version. 
 
I will let the packages to be released to close the bug. 
Comment 3 Alex Lancaster 2005-10-11 18:51:47 EDT
Did a clean install: "yum remove R-mAr", followed by a "yum install R-mAr". 
Error messages gone.  Closing bug.

Note You need to log in before you can comment on or make changes to this bug.