Bug 17034 - Ethernet Card Driver (Tulip) not operating properly.
Ethernet Card Driver (Tulip) not operating properly.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-28 10:19 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 20:23:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-08-28 10:19:28 EDT
I have a built in Intel DC21145 Fast Ethernet PCI card on my eMachine
eOne. Apparently the firmware is not acting right with it, it's some low
level error thing happening when its trying to run either PUMP or
dhchcp, stuff like Tx hung, the lines are on the bottom. Attaching a
PCMCIA ethernet card works like a charm, however. So it definitely has
something to do with the ethernet driver for the Intel DC21145 and not
PUMP or dhchcp. And here are the error lines.

Aug 27 09:06:23 localhost syslogd 1.3-3: restart.
Aug 27 09:06:23 localhost syslogd 1.3-3: restart.
Aug 27 09:06:23 localhost syslogd 1.3-3: restart.
Aug 27 09:06:23 localhost syslogd 1.3-3: restart.
Aug 27 09:06:23 localhost syslogd 1.3-3: restart.
Aug 27 09:06:32 localhost kernel: eth0: Tx hung, 9 vs. 7.
Aug 27 09:06:32 localhost kernel: eth0: Transmit timed out, status
e0260000, CSR12 000000c6, resetting...
Aug 27 09:06:34 localhost kernel: cs461x: drain_dac, dma timeout?
Aug 27 09:06:38 localhost kernel: eth0: Tx hung, 10 vs. 7.
Aug 27 09:06:38 localhost kernel: eth0: Transmit timed out, status
e0260000, CSR12 000000c6, resetting...
Aug 27 09:06:50 localhost kernel: eth0: Tx hung, 11 vs. 7.
Aug 27 09:06:50 localhost kernel: eth0: Transmit timed out, status
e0260000, CSR12 000000c6, resetting...
Aug 27 09:07:02 localhost kernel: eth0: Tx hung, 9 vs. 7.
Aug 27 09:07:02 localhost kernel: eth0: Transmit timed out, status
e0260000, CSR12 000000c6, resetting...
Aug 27 09:07:11 localhost kernel: eth0: Tx hung, 10 vs. 7.
Aug 27 09:07:11 localhost kernel: eth0: Transmit timed out, status
e0260000, CSR12 000000c6, resetting...
Aug 27 09:07:17 localhost kernel: eth0: Tx hung, 10 vs. 7.
Aug 27 09:07:17 localhost kernel: eth0: Transmit timed out, status
e0260000, CSR12 000000c6, resetting...
Aug 27 09:07:26 localhost kernel: eth0: Tx hung, 11 vs. 7.
Aug 27 09:07:26 localhost kernel: eth0: Transmit timed out, status
e0260000, CSR12 000000c6, resetting...
Aug 27 09:07:28 localhost dhcpcd[1087]: recvfrom: Network is down
Aug 27 09:08:44 localhost kernel: eth0: Tx hung, 10 vs. 7.
Aug 27 09:08:44 localhost kernel: eth0: Transmit timed out, status
e0260000, CSR12 000000c6, resetting...
Aug 27 09:08:53 localhost kernel: eth0: Tx hung, 11 vs. 7.
Aug 27 09:08:53 localhost kernel: eth0: Transmit timed out, status
e0260000, CSR12 000000c6, resetting...
Aug 27 09:09:08 localhost PAM_unix[628]: (system-auth) session closed for
user root
Aug 27 09:09:08 localhost gnome-name-server[753]: input condition is: 0x10,
exiting
Aug 27 09:09:11 localhost rc: Stopping keytable succeeded
Aug 27 09:09:11 localhost Font Server[593]: terminating
Aug 27 09:09:11 localhost xfs: xfs shutdown succeeded
Aug 27 09:09:11 localhost gpm: gpm shutdown succeeded
Aug 27 09:09:13 localhost sendmail: sendmail shutdown succeeded
Aug 27 09:09:13 localhost atd: atd shutdown succeeded
Aug 27 09:09:13 localhost crond: crond shutdown succeeded
Aug 27 09:09:14 localhost lpd: lpd shutdown succeeded
Aug 27 09:09:14 localhost identd: identd shutdown succeeded
Aug 27 09:09:18 localhost nfslock: lockd shutdown failed
Aug 27 09:09:18 localhost rpc.statd[318]: Caught signal 15, un-registering
and exiting.
Aug 27 09:09:18 localhost nfslock: rpc.statd shutdown succeeded
Aug 27 09:09:19 localhost dd: 1+0 records in
Aug 27 09:09:19 localhost dd: 1+0 records out
Aug 27 09:09:19 localhost random: Saving random seed succeeded
Aug 27 09:09:19 localhost logger: FAIL: Wrong parameter "stop" in apmscript!
Aug 27 09:09:20 localhost apmd: apmd shutdown succeeded
Aug 27 09:09:20 localhost portmap: portmap shutdown succeeded
Aug 27 09:09:21 localhost pcmcia: Shutting down PCMCIA services:
Aug 27 09:09:21 localhost cardmgr[473]: exiting
Aug 27 09:09:21 localhost pcmcia:  cardmgr
Aug 27 09:09:23 localhost pcmcia:  modules
Aug 27 09:09:23 localhost kernel: unloading PCMCIA Card Services
Aug 27 09:09:23 localhost pcmcia: .
Aug 27 09:09:23 localhost rc: Stopping pcmcia succeeded
Aug 27 09:09:24 localhost kernel: Kernel logging (proc) stopped.
Aug 27 09:09:24 localhost kernel: Kernel log daemon terminating.
Aug 27 09:09:25 localhost syslog: klogd shutdown succeeded
Aug 27 09:09:25 localhost exiting on signal 15
Aug 27 21:42:26 localhost syslogd 1.3-3: restart.
Aug 27 21:42:26 localhost syslog: syslogd startup succeeded
Aug 27 21:42:26 localhost syslog: klogd startup succeeded
Aug 27 21:42:26 localhost kernel: klogd 1.3-3, log source = /proc/kmsg started.
Aug 27 21:42:26 localhost kernel: Inspecting /boot/System.map-2.2.16-17
Aug 27 21:42:26 localhost kernel: Loaded 7009 symbols from
/boot/System.map-2.2.16-17.
Aug 27 21:42:26 localhost kernel: Symbols match kernel version 2.2.16.
Aug 27 21:42:26 localhost kernel: Loaded 114 symbols from 6 modules.
Aug 27 21:42:26 localhost kernel: Linux version 2.2.16-17
(root@porky.devel.redhat.com) (gcc version egcs-2.91.66 19990314/Linux
(egcs-1.1.2 release)) #1 Wed Jul 26 16:16:19 EDT 2000
Aug 27 21:42:26 localhost kernel: Detected 434323 kHz processor.
Aug 27 21:42:26 localhost kernel: Console: colour VGA+ 80x25
Aug 27 21:42:26 localhost kernel: Calibrating delay loop... 865.08 BogoMIPS
Aug 27 21:42:26 localhost kernel: Memory: 62896k/65472k available (1024k
kernel code, 412k reserved, 1076k data, 64k init, 0k bigmem)
Aug 27 21:42:26 localhost kernel: Dentry hash table entries: 262144 (order
9, 2048k)
Aug 27 21:42:26 localhost kernel: Buffer cache hash table entries: 65536
(order 6, 256k)
Aug 27 21:42:26 localhost kernel: Page cache hash table entries: 16384
(order 4, 64k)
Aug 27 21:42:26 localhost kernel: VFS: Diskquotas version dquot_6.4.0
initialized
Aug 27 21:42:26 localhost kernel: CPU: Intel Celeron (Mendocino) stepping 05
Aug 27 21:42:26 localhost kernel: Checking 386/387 coupling... OK, FPU
using exception 16 error reporting.
Aug 27 21:42:26 localhost kernel: Checking 'hlt' instruction... OK.
Aug 27 21:42:26 localhost kernel: POSIX conformance testing by UNIFIX
Aug 27 21:42:26 localhost kernel: mtrr: v1.35a (19990819) Richard Gooch
(rgooch@atnf.csiro.au)
Aug 27 21:42:26 localhost kernel: PCI: PCI BIOS revision 2.10 entry at 0xfd9b6
Aug 27 21:42:26 localhost kernel: PCI: Using configuration type 1
Aug 27 21:42:26 localhost kernel: PCI: Probing PCI hardware
Aug 27 21:42:26 localhost kernel: Linux NET4.0 for Linux 2.2
Aug 27 21:42:26 localhost kernel: Based upon Swansea University Computer
Society NET3.039
Aug 27 21:42:26 localhost kernel: NET4: Unix domain sockets 1.0 for Linux
NET4.0.
A
Comment 1 Bill Nottingham 2000-08-29 14:08:52 EDT
Try using the old_tulip or de4x5 driver; does that help?
Comment 2 Michael K. Johnson 2001-02-16 14:44:41 EST
*** Bug 17035 has been marked as a duplicate of this bug. ***
Comment 3 Alan Cox 2002-12-14 20:23:24 EST
No reply in 2 years
Comment 4 Lilah Lohmann 2004-11-17 23:56:07 EST
Hi eone Having Person w/o name,

This is a eone/tulip issue which has been solved and explained here:

http://electron.mit.edu/~gsteele/eone/

You have a 10/100 chip that has been crippled to only work as a 10
speed. Your problem is that your card detects as the 10/100 that it is
but is missing it's fuzzy 100 speed chip. That's what you get for
buying an eone. Custom compile for 10 speed full duplex and enjoy. My
$50 eone is a craptastic little RHEL 3 workstation which seems to run
with no problems once properly installed.
Best o Luck,
Lilah

Comment 5 Lilah Lohmann 2004-11-18 00:02:49 EST
Hi eone Having Person w/o name,

This is a eone/tulip issue which has been solved and explained here:

http://electron.mit.edu/~gsteele/eone/

You have a 10/100 chip that has been crippled to only work as a 10
speed. Your problem is that your card detects as the 10/100 that it is
but is missing it's fuzzy 100 speed chip. That's what you get for
buying an eone. Custom compile for 10 speed full duplex and enjoy. My
$50 eone is a craptastic little RHEL 3 workstation which seems to run
with no problems once properly installed.

This solution works on any Redhat that can use the tulip driver.

. o O ( I'm guessing that's anything after 7. )

Best o Luck,
Lilah

Note You need to log in before you can comment on or make changes to this bug.