Bug 170351 - Kernel 2.6.13-1.1526_FC4smp causes HP Array Configuration Utility to fail to detect HP Smart Array controller.
Kernel 2.6.13-1.1526_FC4smp causes HP Array Configuration Utility to fail to ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-10 17:38 EDT by Ronald Hall
Modified: 2015-01-04 17:22 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-15 20:42:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Hall 2005-10-10 17:38:51 EDT
Description of problem:

After installing 2.6.13-1.1526_FC4smp kernel, The HP Array Configuration 
Utility to fail to detect HP Smart Array controller.  HP has two utilities for 
configuring Smart Array cards in Linux:

cpqacuxe-7.17-1
hpacucli-7.40-7

The first is a web based utility, and the 2nd is a CLI utility.  When running 
either of this programs since installed kernel 1526 I get the following error 
in /var/log/messages:

kernel: ioctl32(.hpacucli:3015): Unknown cmd fd(3) cmd
(80084201){00} arg(ffffae9c) on /dev/cciss/c0d0

or

kernel: ioctl32(.acuxebin:9160): Unknown cmd fd(6) cmd
(80084201){00} arg(f72d1118) on /dev/cciss/c0d0

Those messages will repeat if I continually try to refresh my controller list 
to detect my HP/Compaq Smart Array 6402 Controller.  If I boot with an older 
Kernel such as kernel-2.6.12-1.1447_FC4, both utilities function correctly.  
So there seems to be something in the latest Kernel which is breaking this 
program.  Both programs are the latest release from HP of the utilities.


Version-Release number of selected component (if applicable):

kernel-2.6.13-1.1526_FC4

How reproducible:

Every time.

Steps to Reproduce:
1.Boot System.
2.Run cpqacuxe or hpacucli utility.
3.Attempt to detect or scan for controller.

  
Actual results:

kernel: ioctl32(.hpacucli:3015): Unknown cmd fd(3) cmd
(80084201){00} arg(ffffae9c) on /dev/cciss/c0d0

or

kernel: ioctl32(.acuxebin:9160): Unknown cmd fd(6) cmd
(80084201){00} arg(f72d1118) on /dev/cciss/c0d0

Expected results:

Controller should be detected as it is with previous Kernels.

Additional info:
Comment 1 Dave Jones 2005-11-10 14:19:19 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 2 Ronald Hall 2005-11-28 15:55:46 EST
I tried the 1637 kernel, and I am still experiencing the same error.  I also 
tried the 1532 and 1526 kernels with same results.  Only 1447 and previous 
work correctly.
Comment 3 Dave Jones 2005-11-28 16:12:36 EST
I just found a fix for this in the 2.6.15rc tree, which I'll backport to the
next update (Not fixed in todays 2.6.14-1.1644 update, but will be in the first
test update to hit http://people.redhat.com/davej/kernels/Fedora/FC4 later today)

Note You need to log in before you can comment on or make changes to this bug.