Bug 170368 - nscd init.d script doesn't work with chkconfig
nscd init.d script doesn't work with chkconfig
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-10 21:08 EDT by Bevan Bennett
Modified: 2014-03-16 22:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-14 12:53:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bevan Bennett 2005-10-10 21:08:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc3 Firefox/1.0.6

Description of problem:
The nscd init.d script generates incorrect start linkswhen used with chkconfig.
This leads to nscd trying to start at the wrong time and failing during bootup.

The line in question is 
# Required-Start: $syslog
Removing it fixes this problem.

I can find no other init.d scripts that currently use this required line.


Version-Release number of selected component (if applicable):
nscd-2.3.5-10.3

How reproducible:
Always

Steps to Reproduce:
[root@oleg init.d]# chkconfig --add nscd
[root@oleg init.d]# chkconfig nscd on


Actual Results:  [root@oleg init.d]# ls -al /etc/rc?.d/*nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:01 /etc/rc0.d/K74nscd -> ../init.d/nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:01 /etc/rc1.d/K74nscd -> ../init.d/nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:01 /etc/rc2.d/S-1nscd -> ../init.d/nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:01 /etc/rc3.d/S-1nscd -> ../init.d/nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:01 /etc/rc4.d/S-1nscd -> ../init.d/nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:01 /etc/rc5.d/S-1nscd -> ../init.d/nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:01 /etc/rc6.d/K74nscd -> ../init.d/nscd



Expected Results:  [root@oleg init.d]# ls -al /etc/rc?.d/*nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:01 /etc/rc0.d/K74nscd -> ../init.d/nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:01 /etc/rc1.d/K74nscd -> ../init.d/nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:06 /etc/rc2.d/S30nscd -> ../init.d/nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:06 /etc/rc3.d/S30nscd -> ../init.d/nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:06 /etc/rc4.d/S30nscd -> ../init.d/nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:06 /etc/rc5.d/S30nscd -> ../init.d/nscd
lrwxrwxrwx  1 root root 14 Oct 10 18:01 /etc/rc6.d/K74nscd -> ../init.d/nscd


Additional info:

Annoyingly, updating nscd moves my corrected script to nscd.rpmsave and restores the broken behavior.
Comment 1 Chris Schanzle 2005-11-04 13:57:30 EST
Confirmed here too today.  Likely related to 168457.  Mangling or deleting the
'Required-Start:' text/line and cleaning up bad links restores expected behavior
(until the next nscd update, as noted above).   Note that init script
"xendomains" appears to work properly; adding identical Default-Start:,
Default-Stop:, Should-Start: and Should-Stop: lines to nscd script did not help.
 Time to read the chkconfig source...

Helpful cleanup cmd:
  find /etc/rc.d -name '*-1nscd' | xargs rm -v

Current relevant packages:  
  rpm -q nscd chkconfig xen
nscd-2.3.5-10.3
chkconfig-1.3.20-1
xen-2-20050823
Comment 2 Bill Nottingham 2005-11-14 12:53:19 EST
This is fixed with the current rawhide and/or FC4 update chkconfig.
Comment 3 Chris Schanzle 2005-11-14 13:33:36 EST
Errata works for me.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.