Bug 170377 - KMail saves blank ImapPath in kmailrc and crashes when rereading the file
KMail saves blank ImapPath in kmailrc and crashes when rereading the file
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-10-11 03:28 EDT by Adam Szalkowski
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-01 08:03:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Szalkowski 2005-10-11 03:28:50 EDT
Description of problem:


Version-Release number of selected component (if applicable):
kdepim-3.4.91-1.x86_64

How reproducible:
quite often, happenend 2 times since 3.4.91

Steps to Reproduce:
1.create an IMAP account in kmail
2.quit or kill kmail
3.reopen kmail and it will crash
  
Actual results:
kmail saves its .kde/share/config/kmailrc with blank entries for "ImapPath" and
crashes when it encounters these lines while parsing config.
I'm not not sure when this saving of the faulty config happens. I've been using
kmail normally and the kmailrc was alright. But it already happened twice that
some "ImapPath"s were saved empty.

Expected results:
kmail should save the "ImapPath"s each time the configuration changes and not
leave them suddenly blank.

Additional info:
I think it is an additional bug that kmail crashes when it encounters empty
"ImapPath"s. Maybe some recovery could be done in such a case.
Here's a part of my kmailrc and you can see that ImapPath is empty what it
should certainly not:

[Folder-.75360328.directory/Chor2]
Compactable=true
ContentsType=0
Current=356
CurrentSerialNum=1375067
ExpireAction=Delete
ExpireMessages=false
ExpireToFolder=
Id=0
Identity=5242955
IgnoreNewMail=false
ImapPath=
MailingListArchiveAddress=
MailingListEnabled=false
MailingListFeatures=0
MailingListHandler=0
MailingListHelpAddress=
MailingListId=
MailingListPostingAddress=
MailingListSubscribeAddress=
MailingListUnsubscribeAddress=
NoContent=false
NormalIconPath=
OrderOfArrival=false
PutRepliesInSameFolder=true
ReadExpireAge=14
ReadExpireUnits=0
ReadOnly=true
SortColumn=3
Status=false
SystemLabel=
Top=341
TotalMsgs=360
UidValidity=
UnreadExpireAge=28
UnreadExpireUnits=0
UnreadIconPath=
UnreadMsgs=0
UseCustomIcons=false
WhoField=
checkmail=true
htmlLoadExternalOverride=false
htmlMailOverride=false
isOpen=true
threadMessagesBySubject=true
threadMessagesOverride=false

Note You need to log in before you can comment on or make changes to this bug.